summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD34
-rw-r--r--gnome-twitch.install16
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b624dc03d771
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = gnome-twitch
+ pkgdesc = Enjoy Twitch on your GNU/Linux desktop
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/Ippytraxx/gnome-twitch
+ install = gnome-twitch.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ depends = gtk3
+ depends = libsoup
+ depends = json-glib
+ depends = gstreamer
+ depends = gst-libav
+ depends = gst-plugins-base
+ depends = gst-plugins-good
+ depends = gst-plugins-bad
+ depends = gst-plugins-ugly
+ depends = clutter-gst
+ depends = clutter-gtk
+ conflicts = gnome-twitch-git
+ source = https://github.com/Ippytraxx/gnome-twitch/archive/v0.1.0.tar.gz
+ md5sums = 1047adaf29d2c948b68162d129a19fed
+
+pkgname = gnome-twitch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26c5f7aebf22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Vincent <ippytraxx@installgentoo.com>
+
+pkgname=gnome-twitch
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Enjoy Twitch on your GNU/Linux desktop"
+arch=('i686' 'x86_64')
+url="https://github.com/Ippytraxx/gnome-twitch"
+license=('GPL3')
+makedepends=('git' 'meson')
+depends=('gtk3' 'libsoup' 'json-glib' 'gstreamer' 'gst-libav' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-bad' 'gst-plugins-ugly' 'clutter-gst' 'clutter-gtk')
+conflicts=('gnome-twitch-git')
+install=gnome-twitch.install
+source=("https://github.com/Ippytraxx/gnome-twitch/archive/v${pkgver}.tar.gz")
+md5sums=('1047adaf29d2c948b68162d129a19fed')
+
+build()
+{
+ ls
+ cd "${pkgname}-${pkgver}"
+ mkdir build
+ meson . build
+ cd build
+ ninja
+}
+
+package()
+{
+ cd "${pkgname}-${pkgver}"
+ cd build
+ mesonconf -Dprefix=/usr
+ mesonconf -Dtype=release
+ DESTDIR="$pkgdir" ninja install
+}
diff --git a/gnome-twitch.install b/gnome-twitch.install
new file mode 100644
index 000000000000..c0c2237a5c22
--- /dev/null
+++ b/gnome-twitch.install
@@ -0,0 +1,16 @@
+post_install()
+{
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_upgrade()
+{
+ post_install
+}
+
+post_remove()
+{
+ post_install
+}