summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed92d4be94eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gnome-video-effects-git
+ pkgdesc = Collection of GStreamer effects for GNOME
+ pkgver = 0.5.0+7+g98cd0b2
+ pkgrel = 1
+ url = https://gitlab.gnome.org/GNOME/gnome-video-effects
+ arch = any
+ license = GPL2
+ makedepends = meson
+ makedepends = git
+ depends = gst-plugins-good
+ depends = gst-plugins-bad
+ depends = frei0r-plugins
+ provides = gnome-video-effects
+ conflicts = gnome-video-effects
+ source = git+https://gitlab.gnome.org/GNOME/gnome-video-effects.git
+ sha512sums = SKIP
+
+pkgname = gnome-video-effects-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..327d4ca4b00e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+pkgname=gnome-video-effects-git
+_pkgname=gnome-video-effects
+pkgver=0.5.0+7+g98cd0b2
+pkgrel=1
+pkgdesc="Collection of GStreamer effects for GNOME"
+arch=(any)
+url="https://gitlab.gnome.org/GNOME/gnome-video-effects"
+license=(GPL2)
+depends=('gst-plugins-good' 'gst-plugins-bad' 'frei0r-plugins')
+makedepends=('meson' 'git')
+provides=('gnome-video-effects')
+conflicts=('gnome-video-effects')
+source=("git+https://gitlab.gnome.org/GNOME/gnome-video-effects.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ arch-meson $_pkgname build
+ ninja -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}
+
+# vim:set ts=2 sw=2 et: