summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD48
2 files changed, 42 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4fa9f62fff45..0cebe81e6ac0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,24 @@
pkgbase = gnome-weather-git
pkgdesc = Access current weather conditions and forecasts
- pkgver = 3.34.0+27+g07c3cf5
+ pkgver = 44.0+20+g741d71c
pkgrel = 1
url = https://wiki.gnome.org/Apps/Weather
arch = any
groups = gnome
+ groups = gnome-git
license = GPL
- makedepends = gobject-introspection
makedepends = appstream-glib
makedepends = git
+ makedepends = gobject-introspection
makedepends = meson
- depends = gtk3
+ depends = geoclue
depends = gjs
- depends = libgweather
- depends = geoclue2
- depends = gnome-desktop
+ depends = gtk4
+ depends = libadwaita
+ depends = libgweather-4
provides = gnome-weather
conflicts = gnome-weather
source = git+https://gitlab.gnome.org/GNOME/gnome-weather.git
sha512sums = SKIP
pkgname = gnome-weather-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 8e9f1665afb9..4dc91555ff16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,47 @@
-pkgname=gnome-weather-git
-_pkgname=gnome-weather
-pkgver=3.34.0+27+g07c3cf5
+# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
+
+_pkgname="gnome-weather"
+pkgname="${_pkgname}-git"
+pkgver=44.0+20+g741d71c
pkgrel=1
pkgdesc="Access current weather conditions and forecasts"
url="https://wiki.gnome.org/Apps/Weather"
arch=(any)
license=(GPL)
-depends=('gtk3' 'gjs' 'libgweather' 'geoclue2' 'gnome-desktop')
-makedepends=('gobject-introspection' 'appstream-glib' 'git' 'meson')
-provides=('gnome-weather')
-conflicts=('gnome-weather')
-groups=('gnome')
-source=("git+https://gitlab.gnome.org/GNOME/gnome-weather.git")
+depends=(
+ geoclue
+ gjs
+ gtk4
+ libadwaita
+ libgweather-4
+)
+makedepends=(
+ appstream-glib
+ git
+ gobject-introspection
+ meson
+)
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+groups=(
+ gnome
+ gnome-git
+)
+source=("git+https://gitlab.gnome.org/GNOME/${_pkgname}.git")
sha512sums=('SKIP')
pkgver() {
- cd $_pkgname
+ cd "${_pkgname}"
git describe --tags | sed 's/-/+/g'
}
+prepare() {
+ cd "${_pkgname}"
+}
+
build() {
- arch-meson $_pkgname build
- ninja -C build
+ arch-meson "${_pkgname}" build
+ meson compile -C build
}
check() {
@@ -29,5 +49,7 @@ check() {
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "${pkgdir}"
}
+
+# vim:set sw=2 sts=-1 et: