summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO46
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD55
-rw-r--r--gns3-server@.service7
-rw-r--r--requirements.txt11
5 files changed, 84 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc3514aa2466..bb62b4f0ecbf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,37 +1,43 @@
pkgbase = gns3-server-git
pkgdesc = GNS3 network simulator, Server package
- pkgver = v2.1.9.r26.geb0e26b5
+ pkgver = v2.2.39.r24.g25c03b78
pkgrel = 1
url = https://github.com/GNS3/gns3-server
install = gns3-server.install
arch = x86_64
+ arch = aarch64
groups = gns3
license = GPL3
makedepends = git
- makedepends = python-setuptools
- depends = python-jsonschema
- depends = python-aiohttp-gns3
- depends = python-aiohttp-cors-gns3
- depends = python-yarl-gns3
+ depends = busybox
+ depends = python-aiofiles
+ depends = python-aiohttp
+ depends = python-aiohttp-cors
+ depends = python-async_generator
+ depends = python-async-timeout
+ depends = python-distro
+ depends = python-importlib_resources
depends = python-jinja
- depends = python-raven
+ depends = python-jsonschema
+ depends = python-prompt_toolkit
depends = python-psutil
- depends = python-zipstream-gns3
- depends = python-prompt_toolkit-gns3
- depends = python-async-timeout-gns3
- depends = busybox
- optdepends = dynamips: Cisco router emulator.
- optdepends = gns3-gui: graphical user interface for GNS3 server.
- optdepends = iouyap: Bridge IOU to UDP, TAP and Ethernet.
- optdepends = qemu: Used by GNS3 to run Cisco ASA, PIX and IDS.
- optdepends = vpcs: Simple PC emulation for basic network operations.
- optdepends = ubridge: Bridge for UDP tunnels, Ethernet, TAP and VMnet interfaces.
+ depends = python-py-cpuinfo
+ depends = python-sentry_sdk
+ depends = python-setuptools
+ depends = python-yarl
+ optdepends = dynamips: Cisco router emulator
+ optdepends = gns3-gui-git: graphical user interface for GNS3 server
+ optdepends = qemu: Used by GNS3 to run Cisco ASA, PIX and IDS
+ optdepends = libvirt: needed for the NAT cloud
+ optdepends = vpcs: Simple PC emulation for basic network operations
+ optdepends = ubridge: Bridge for UDP tunnels, Ethernet, TAP and VMnet interfaces
provides = gns3-server
conflicts = gns3-server
- source = gns3-server::git+git://github.com/GNS3/gns3-server.git#branch=2.1
+ source = gns3-server::git+https://github.com/GNS3/gns3-server.git
source = gns3-server@.service
+ source = requirements.txt
sha256sums = SKIP
- sha256sums = d145c7a4b7163aecd91b71a0769130d62beb5f4381fe5437774f6b4477a3fa48
+ sha256sums = b43f0ead963a06e613d3303d2c66372b57f46c750b3d6df20eb99c11078de65f
+ sha256sums = e4ef269501f66d0897c0625e609929d436eef6c7c0d14c5ea68ed616d9ab24be
pkgname = gns3-server-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f443b1b8e818
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*~
+*.log
+gns3-server
+gns3-server-git-*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index ac09bd3936fe..c7b42a48ea67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,38 +3,61 @@
_pkgname=gns3-server
pkgname=$_pkgname-git
-pkgver=v2.1.9.r26.geb0e26b5
+pkgver=v2.2.39.r24.g25c03b78
pkgrel=1
pkgdesc='GNS3 network simulator, Server package'
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url='https://github.com/GNS3/gns3-server'
license=('GPL3')
groups=('gns3')
provides=("$_pkgname")
conflicts=("$_pkgname")
-makedepends=('git' 'python-setuptools')
-depends=('python-jsonschema' 'python-aiohttp-gns3' 'python-aiohttp-cors-gns3'
- 'python-yarl-gns3' 'python-jinja' 'python-raven' 'python-psutil'
- 'python-zipstream-gns3' 'python-prompt_toolkit-gns3' 'python-async-timeout-gns3'
- 'busybox')
-optdepends=('dynamips: Cisco router emulator.'
- 'gns3-gui: graphical user interface for GNS3 server.'
- 'iouyap: Bridge IOU to UDP, TAP and Ethernet.'
- 'qemu: Used by GNS3 to run Cisco ASA, PIX and IDS.'
- 'vpcs: Simple PC emulation for basic network operations.'
- 'ubridge: Bridge for UDP tunnels, Ethernet, TAP and VMnet interfaces.'
+makedepends=('git')
+depends=(
+ 'busybox'
+ 'python-aiofiles'
+ 'python-aiohttp'
+ 'python-aiohttp-cors'
+ 'python-async_generator'
+ 'python-async-timeout'
+ 'python-distro'
+ 'python-importlib_resources'
+ 'python-jinja'
+ 'python-jsonschema'
+ 'python-prompt_toolkit'
+ 'python-psutil'
+ 'python-py-cpuinfo'
+ 'python-sentry_sdk'
+ 'python-setuptools'
+ 'python-yarl'
+)
+optdepends=(
+ 'dynamips: Cisco router emulator'
+ 'gns3-gui-git: graphical user interface for GNS3 server'
+ 'qemu: Used by GNS3 to run Cisco ASA, PIX and IDS'
+ 'libvirt: needed for the NAT cloud'
+ 'vpcs: Simple PC emulation for basic network operations'
+ 'ubridge: Bridge for UDP tunnels, Ethernet, TAP and VMnet interfaces'
)
install="$_pkgname.install"
-source=("$_pkgname::git+git://github.com/GNS3/$_pkgname.git#branch=2.1"
- "$_pkgname@.service")
+source=("$_pkgname::git+https://github.com/GNS3/$_pkgname.git"
+ "$_pkgname@.service"
+ requirements.txt)
sha256sums=('SKIP'
- 'd145c7a4b7163aecd91b71a0769130d62beb5f4381fe5437774f6b4477a3fa48')
+ 'b43f0ead963a06e613d3303d2c66372b57f46c750b3d6df20eb99c11078de65f'
+ 'e4ef269501f66d0897c0625e609929d436eef6c7c0d14c5ea68ed616d9ab24be')
pkgver() {
cd "$_pkgname"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$_pkgname"
+ # Arch usually has the latest versions. Patch requirements to allow them.
+ cp "$srcdir"/requirements.txt .
+}
+
build() {
cd "$_pkgname"
python setup.py build
diff --git a/gns3-server@.service b/gns3-server@.service
index 2626d09cfce7..ade083ecd808 100644
--- a/gns3-server@.service
+++ b/gns3-server@.service
@@ -1,10 +1,11 @@
[Unit]
-Description=gns3 server for %i
-After=network.target
+Description=GNS3 server for %i
[Service]
+Type=simple
User=%i
-ExecStart=/usr/bin/gns3server --local
+ExecStart=/usr/bin/gns3server
+Restart=on-failure
[Install]
WantedBy=multi-user.target
diff --git a/requirements.txt b/requirements.txt
new file mode 100644
index 000000000000..33b970e934bb
--- /dev/null
+++ b/requirements.txt
@@ -0,0 +1,11 @@
+jsonschema>=4.17.3
+aiohttp>=3.8.4
+aiohttp-cors>=0.7.0
+aiofiles>=22.1.0
+Jinja2>=3.1.2
+sentry-sdk>=1.17.0
+psutil>=5.9.4
+async-timeout>=4.0.2
+distro>=1.8.0
+py-cpuinfo>=9.0.0
+setuptools>=60.8.1