summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
-rw-r--r--gns3-server@.service7
3 files changed, 23 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a921fe4b260..e8d45bffa309 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gns3-server-git
pkgdesc = GNS3 network simulator, Server package
- pkgver = v2.2.9.r0.gc0c81514
+ pkgver = v2.2.20.r4.g4e61cc81
pkgrel = 1
url = https://github.com/GNS3/gns3-server
install = gns3-server.install
@@ -23,20 +23,18 @@ pkgbase = gns3-server-git
depends = python-py-cpuinfo
depends = python-sentry_sdk
depends = python-yarl
- depends = python-zipstream-gns3
- optdepends = dynamips: Cisco router emulator.
- optdepends = gns3-gui-git: graphical user interface for GNS3 server.
- optdepends = iouyap: Bridge IOU to UDP, TAP and Ethernet.
- optdepends = qemu: Used by GNS3 to run Cisco ASA, PIX and IDS.
+ optdepends = dynamips: Cisco router emulator
+ optdepends = gns3-gui-git: graphical user interface for GNS3 server
+ optdepends = qemu: Used by GNS3 to run Cisco ASA, PIX and IDS
optdepends = libvirt: needed for the NAT cloud
- optdepends = vpcs: Simple PC emulation for basic network operations.
- optdepends = ubridge: Bridge for UDP tunnels, Ethernet, TAP and VMnet interfaces.
+ optdepends = vpcs: Simple PC emulation for basic network operations
+ optdepends = ubridge: Bridge for UDP tunnels, Ethernet, TAP and VMnet interfaces
provides = gns3-server
conflicts = gns3-server
source = gns3-server::git+git://github.com/GNS3/gns3-server.git
source = gns3-server@.service
sha256sums = SKIP
- sha256sums = d145c7a4b7163aecd91b71a0769130d62beb5f4381fe5437774f6b4477a3fa48
+ sha256sums = b43f0ead963a06e613d3303d2c66372b57f46c750b3d6df20eb99c11078de65f
pkgname = gns3-server-git
diff --git a/PKGBUILD b/PKGBUILD
index 5dabae6e6ecc..2b1f496f9de9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=gns3-server
pkgname=$_pkgname-git
-pkgver=v2.2.9.r0.gc0c81514
+pkgver=v2.2.20.r4.g4e61cc81
pkgrel=1
pkgdesc='GNS3 network simulator, Server package'
arch=('x86_64')
@@ -28,22 +28,20 @@ depends=(
'python-py-cpuinfo'
'python-sentry_sdk'
'python-yarl'
- 'python-zipstream-gns3'
)
optdepends=(
- 'dynamips: Cisco router emulator.'
- 'gns3-gui-git: graphical user interface for GNS3 server.'
- 'iouyap: Bridge IOU to UDP, TAP and Ethernet.'
- 'qemu: Used by GNS3 to run Cisco ASA, PIX and IDS.'
+ 'dynamips: Cisco router emulator'
+ 'gns3-gui-git: graphical user interface for GNS3 server'
+ 'qemu: Used by GNS3 to run Cisco ASA, PIX and IDS'
'libvirt: needed for the NAT cloud'
- 'vpcs: Simple PC emulation for basic network operations.'
- 'ubridge: Bridge for UDP tunnels, Ethernet, TAP and VMnet interfaces.'
+ 'vpcs: Simple PC emulation for basic network operations'
+ 'ubridge: Bridge for UDP tunnels, Ethernet, TAP and VMnet interfaces'
)
install="$_pkgname.install"
source=("$_pkgname::git+git://github.com/GNS3/$_pkgname.git"
"$_pkgname@.service")
sha256sums=('SKIP'
- 'd145c7a4b7163aecd91b71a0769130d62beb5f4381fe5437774f6b4477a3fa48')
+ 'b43f0ead963a06e613d3303d2c66372b57f46c750b3d6df20eb99c11078de65f')
pkgver() {
cd "$_pkgname"
@@ -52,9 +50,12 @@ pkgver() {
prepare() {
cd "$_pkgname"
+ # Arch usually has the latest versions. Patch requirements to allow them.
sed -i \
- -e 's|^aiofiles==0\.4\.0$|aiofiles>=0.4.0|' \
- -e 's|^psutil==5\.6\.6$|psutil>=5.6.6|' \
+ -e 's|^aiohttp==3\.7\.4.*|aiohttp>=3.7.4|' \
+ -e 's|^aiofiles==0\.6\.0$|aiofiles>=0.6.0|' \
+ -e 's|^psutil==5\.8\.0$|psutil>=5.8.0|' \
+ -e 's|^distro==1\.5\.0$|distro>=1.5.0|' \
requirements.txt
}
diff --git a/gns3-server@.service b/gns3-server@.service
index 2626d09cfce7..ade083ecd808 100644
--- a/gns3-server@.service
+++ b/gns3-server@.service
@@ -1,10 +1,11 @@
[Unit]
-Description=gns3 server for %i
-After=network.target
+Description=GNS3 server for %i
[Service]
+Type=simple
User=%i
-ExecStart=/usr/bin/gns3server --local
+ExecStart=/usr/bin/gns3server
+Restart=on-failure
[Install]
WantedBy=multi-user.target