summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD48
-rw-r--r--xbt.patch32
3 files changed, 43 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 443ac8839653..53a2d46aa707 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,24 @@
-# Generated by mksrcinfo v8
-# sob gru 30 11:20:19 UTC 2017
pkgbase = gnucash-xbt
pkgdesc = A personal and small-business financial-accounting application with Bitcoin support
- pkgver = 2.6.19
+ pkgver = 3.0
pkgrel = 1
url = http://www.gnucash.org
arch = i686
arch = x86_64
license = GPL
- makedepends = intltool
- makedepends = gcc
- makedepends = pkgconfig
- depends = guile2.0
- depends = slib
- depends = goffice0.8
- depends = libdbi-drivers
+ makedepends = boost
+ makedepends = gmock
+ makedepends = gwenhywfar
+ makedepends = cmake
depends = libmariadbclient
depends = postgresql-libs
depends = aqbanking
- depends = desktop-file-utils
- depends = webkitgtk2
- depends = libgnome-keyring
- depends = libgnomecanvas
- depends = dconf
- optdepends = evince: for print preview
- optdepends = yelp: help browser
+ depends = webkit2gtk
+ depends = boost-libs
+ depends = libsecret
+ depends = libdbi-drivers
+ optdepends = gnucash-docs: for documentation
+ optdepends = iso-codes: for translation of currency names
optdepends = perl-finance-quote: for stock information lookups
optdepends = perl-date-manip: for stock information lookups
provides = gnucash
@@ -32,10 +26,10 @@ pkgbase = gnucash-xbt
conflicts = gnucash-devel
options = !makeflags
options = !emptydirs
- source = https://github.com/Gnucash/gnucash/releases/download/2.6.19/gnucash-2.6.19.tar.bz2
+ source = https://github.com/Gnucash/gnucash/releases/download/3.0/gnucash-3.0.tar.bz2
source = xbt.patch
- sha1sums = d2ae5c7855fac30d88fe889d47a441e8a887b19c
- sha1sums = 7244b9cc71d0d03c43055c062f3eeba5e3544630
+ sha1sums = a575e853668b93b34dcd94f0ef0d1fee25b0165f
+ sha1sums = 52cf6820bf1dd87b5807997e49ec9c861ff516af
pkgname = gnucash-xbt
diff --git a/PKGBUILD b/PKGBUILD
index 9217b9fae1d6..319445bc087c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,48 +2,54 @@
pkgname=gnucash-xbt
_pkgname=gnucash
-pkgver=2.6.19
+pkgver=3.0
pkgrel=1
_sourcerel=
pkgdesc="A personal and small-business financial-accounting application with Bitcoin support"
arch=('i686' 'x86_64')
url="http://www.gnucash.org"
license=("GPL")
-depends=('guile2.0' 'slib' 'goffice0.8' 'libdbi-drivers' 'libmariadbclient' 'postgresql-libs' 'aqbanking' 'desktop-file-utils' 'webkitgtk2' 'libgnome-keyring' 'libgnomecanvas' 'dconf')
-makedepends=('intltool' 'gcc' 'pkgconfig')
-optdepends=('evince: for print preview'
- 'yelp: help browser'
- 'perl-finance-quote: for stock information lookups'
- 'perl-date-manip: for stock information lookups')
+depends=('libmariadbclient' 'postgresql-libs' 'aqbanking' 'webkit2gtk' 'boost-libs' 'libsecret' 'libdbi-drivers')
+makedepends=('boost' 'gmock' 'gwenhywfar' 'cmake')
+optdepends=(
+ 'gnucash-docs: for documentation'
+ 'iso-codes: for translation of currency names'
+ 'perl-finance-quote: for stock information lookups'
+ 'perl-date-manip: for stock information lookups'
+)
options=('!makeflags' '!emptydirs')
conflicts=('gnucash' 'gnucash-devel')
provides=('gnucash')
source=("https://github.com/Gnucash/${_pkgname}/releases/download/${pkgver}/${_pkgname}-${pkgver}${_sourcerel}.tar.bz2"
"xbt.patch")
-sha1sums=('d2ae5c7855fac30d88fe889d47a441e8a887b19c'
- '7244b9cc71d0d03c43055c062f3eeba5e3544630')
+sha1sums=('a575e853668b93b34dcd94f0ef0d1fee25b0165f'
+ '52cf6820bf1dd87b5807997e49ec9c861ff516af')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
patch -Np0 -i "${srcdir}/xbt.patch"
+
+ cd "${srcdir}"
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DCMAKE_INSTALL_LIBEXECDIR=/usr/lib \
+ -DCOMPILE_GSCHEMAS=NO \
+ -DWITH_OFX=ON \
+ -DWITH_AQBANKING=ON \
+ "${srcdir}/${_pkgname}-${pkgver}"
}
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- ./configure --prefix=/usr --mandir=/usr/share/man --sysconfdir=/etc \
- --libexecdir=/usr/lib --disable-schemas-compile --enable-ofx --enable-aqbanking
- make GUILD=/usr/bin/guild2.0
+ cd "${srcdir}/build"
+
+ make
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 DESTDIR="${pkgdir}" install
- cd src/doc/design
- make DESTDIR="${pkgdir}" install-info
-
- install -dm755 "${pkgdir}/usr/share/gconf/schemas"
- gconf-merge-schema "${pkgdir}/usr/share/gconf/schemas/${_pkgname}.schemas" --domain gnucash "${pkgdir}"/etc/gconf/schemas/*.schemas
- rm -f "${pkgdir}"/etc/gconf/schemas/*.schemas
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}" install
# Delete the gnucash-valgrind executable because the source files
# are not included with the package and the executable is hardlinked
diff --git a/xbt.patch b/xbt.patch
index 1940071f7a53..7ae0788b3dea 100644
--- a/xbt.patch
+++ b/xbt.patch
@@ -1,33 +1,5 @@
---- src/engine/iso-4217-currencies.c.orig 2015-01-02 18:34:12.445021803 +0100
-+++ src/engine/iso-4217-currencies.c 2015-01-02 18:38:34.565784519 +0100
-@@ -4142,6 +4142,24 @@
- }
-
- {
-+ const char *fullname = "Bitcoin";
-+ gnc_commodity *c = gnc_commodity_new(book,
-+ CUR_I18N(fullname),
-+ "ISO4217",
-+ "XBT",
-+ "nil",
-+ 1000000);
-+
-+ if(!c) {
-+ PWARN("failed to create commodity for currency %s", fullname);
-+ } else {
-+ if(!gnc_commodity_table_insert(table, c)) {
-+ PWARN("failed to insert %s into commodity table", fullname);
-+ }
-+ }
-+ }
-+
-+ {
- const char *fullname = "Silver";
- gnc_commodity *c = gnc_commodity_new(book,
- CUR_I18N(fullname),
-
---- src/engine/iso-4217-currencies.xml.orig 2015-04-04 08:48:15.854870167 +0200
-+++ src/engine/iso-4217-currencies.xml 2015-04-04 08:48:32.791594789 +0200
+--- libgnucash/engine/iso-4217-currencies.xml.orig 2015-04-04 08:48:15.854870167 +0200
++++ libgnucash/engine/iso-4217-currencies.xml 2015-04-04 08:48:32.791594789 +0200
@@ -2953,6 +2953,20 @@
smallest-fraction="1000000"
local-symbol=""