summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
-rw-r--r--gcc8.patch13
3 files changed, 37 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3ea1f05642a..422bf74ea4a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = gnucash-xbt
pkgdesc = A personal and small-business financial-accounting application with Bitcoin support
pkgver = 3.1
- pkgrel = 1
+ pkgrel = 2
url = http://www.gnucash.org
- arch = i686
arch = x86_64
license = GPL
makedepends = boost
+ makedepends = cmake
makedepends = gmock
makedepends = gwenhywfar
- makedepends = cmake
- depends = libmariadbclient
- depends = postgresql-libs
+ makedepends = libdbi
+ makedepends = libdbi-drivers
+ makedepends = libmariadbclient
+ makedepends = postgresql-libs
depends = aqbanking
- depends = webkit2gtk
depends = boost-libs
+ depends = webkit2gtk
depends = libsecret
- depends = libdbi-drivers
optdepends = gnucash-docs: for documentation
optdepends = iso-codes: for translation of currency names
optdepends = perl-finance-quote: for stock information lookups
@@ -28,8 +28,10 @@ pkgbase = gnucash-xbt
options = !emptydirs
source = https://github.com/Gnucash/gnucash/releases/download/3.1/gnucash-3.1-1.tar.bz2
source = xbt.patch
+ source = gcc8.patch
sha1sums = 8ba1e61db532571e9c5423caadfbc551f6fb1b82
sha1sums = 52cf6820bf1dd87b5807997e49ec9c861ff516af
+ sha1sums = 26704ecc0d611eff806b6bc7c3f1b632f1348980
pkgname = gnucash-xbt
diff --git a/PKGBUILD b/PKGBUILD
index 1d78c0d5b203..0c2817822dd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,31 +3,34 @@
pkgname=gnucash-xbt
_pkgname=gnucash
pkgver=3.1
-pkgrel=1
+pkgrel=2
_sourcerel=-1
pkgdesc="A personal and small-business financial-accounting application with Bitcoin support"
-arch=('i686' 'x86_64')
+arch=(x86_64)
url="http://www.gnucash.org"
-license=("GPL")
-depends=('libmariadbclient' 'postgresql-libs' 'aqbanking' 'webkit2gtk' 'boost-libs' 'libsecret' 'libdbi-drivers')
-makedepends=('boost' 'gmock' 'gwenhywfar' 'cmake')
+license=(GPL)
+depends=(aqbanking boost-libs webkit2gtk libsecret)
+makedepends=(boost cmake gmock gwenhywfar libdbi libdbi-drivers libmariadbclient postgresql-libs)
optdepends=(
'gnucash-docs: for documentation'
'iso-codes: for translation of currency names'
'perl-finance-quote: for stock information lookups'
'perl-date-manip: for stock information lookups'
)
-options=('!makeflags' '!emptydirs')
-conflicts=('gnucash' 'gnucash-devel')
-provides=('gnucash')
+options=(!makeflags !emptydirs)
+conflicts=(gnucash gnucash-devel)
+provides=(gnucash)
source=("https://github.com/Gnucash/${_pkgname}/releases/download/${pkgver}/${_pkgname}-${pkgver}${_sourcerel}.tar.bz2"
- "xbt.patch")
+ "xbt.patch"
+ "gcc8.patch")
sha1sums=('8ba1e61db532571e9c5423caadfbc551f6fb1b82'
- '52cf6820bf1dd87b5807997e49ec9c861ff516af')
+ '52cf6820bf1dd87b5807997e49ec9c861ff516af'
+ '26704ecc0d611eff806b6bc7c3f1b632f1348980')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
patch -Np0 -i "${srcdir}/xbt.patch"
+ patch -Np0 -i "${srcdir}/gcc8.patch"
cd "${srcdir}"
mkdir build
@@ -35,6 +38,7 @@ prepare() {
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=/usr/lib \
-DCMAKE_INSTALL_LIBEXECDIR=/usr/lib \
+ -DHAVE_GWEN_GTK3=ON \
-DCOMPILE_GSCHEMAS=NO \
-DWITH_OFX=ON \
-DWITH_AQBANKING=ON \
@@ -44,7 +48,7 @@ prepare() {
build() {
cd "${srcdir}/build"
- make
+ make -j8
}
package() {
diff --git a/gcc8.patch b/gcc8.patch
new file mode 100644
index 000000000000..064df51fc24c
--- /dev/null
+++ b/gcc8.patch
@@ -0,0 +1,13 @@
+--- CMakeLists.txt 2018-06-13 08:20:55.012756800 +0200
++++ CMakeLists.txt 2018-06-13 08:23:34.179228185 +0200
+@@ -551,8 +551,8 @@
+
+ IF (UNIX)
+ SET( CMAKE_C_FLAGS "-Werror -Wdeclaration-after-statement -Wno-pointer-sign -Wall -Wmissing-prototypes -Wmissing-declarations -Wno-unused ${CMAKE_C_FLAGS}")
+- SET( CMAKE_CXX_FLAGS "-Werror -Wall -Wmissing-declarations -Wno-unused ${CMAKE_CXX_FLAGS}")
+- SET( CMAKE_C_FLAGS "-Wno-deprecated-declarations -std=gnu11 ${CMAKE_C_FLAGS}")
++ SET( CMAKE_CXX_FLAGS "-Werror -Wall -Wmissing-declarations -Wno-unused -Wno-error=parentheses ${CMAKE_CXX_FLAGS}")
++ SET( CMAKE_C_FLAGS "-Wno-deprecated-declarations -std=gnu11 -Wno-error=parentheses ${CMAKE_C_FLAGS}")
+ SET( CMAKE_C_FLAGS_RELEASE "-O3 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 ${CMAKE_C_FLAGS}")
+ ENDIF (UNIX)
+ IF (MINGW)