summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--0001-Fix-compiler-warning-issues.patch28
-rw-r--r--PKGBUILD22
3 files changed, 19 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8902b79fe49..927a217843ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = gnucash-xbt-minimal
pkgdesc = A personal and small-business financial-accounting application with Bitcoin but without ofx/qfx import and aqbanking support
- pkgver = 3.2
- pkgrel = 2
+ pkgver = 5.5
+ pkgrel = 1
url = http://www.gnucash.org
arch = x86_64
+ arch = aarch64
license = GPL
makedepends = boost
makedepends = cmake
makedepends = gmock
- makedepends = libdbi
- makedepends = libdbi-drivers
makedepends = libmariadbclient
makedepends = postgresql-libs
+ makedepends = swig
depends = webkit2gtk
depends = boost-libs
+ depends = libdbi
+ depends = libdbi-drivers
depends = guile
depends = libsecret
optdepends = gnucash-docs: for documentation
@@ -25,12 +27,9 @@ pkgbase = gnucash-xbt-minimal
conflicts = gnucash-devel
conflicts = gnucash-xbt
options = !emptydirs
- source = https://github.com/Gnucash/gnucash/releases/download/3.2/gnucash-3.2.tar.bz2
+ source = https://github.com/Gnucash/gnucash/releases/download/5.5/gnucash-5.5.tar.bz2
source = xbt.patch
- source = 0001-Fix-compiler-warning-issues.patch
- sha1sums = 4ab5baf0d7328e7b6f6a0cb0b4fea3864beb17dd
- sha1sums = 52cf6820bf1dd87b5807997e49ec9c861ff516af
- sha1sums = 2a206572b385288fd4a7dd9b2bedb2b793d4ca2b
+ sha256sums = b4daf67bb892b706323f62e9fa97242039d7dd0a2e1e10771e0c25817dd0ed3b
+ sha256sums = 8cf12425a9f66c69473d83582742244889dc0ffb854d3a502aca58bc649878d4
pkgname = gnucash-xbt-minimal
-
diff --git a/0001-Fix-compiler-warning-issues.patch b/0001-Fix-compiler-warning-issues.patch
deleted file mode 100644
index 903a0b006e6c..000000000000
--- a/0001-Fix-compiler-warning-issues.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index b2fcffb17..b2ecf7dc2 100644
---- CMakeLists.txt.orig
-+++ CMakeLists.txt
-@@ -572,8 +572,9 @@ set(CMAKE_CXX_FLAGS "-std=gnu++11 ${CMAKE_CXX_FLAGS}") # FIXME: should be -std=
-
- if (UNIX)
- set( CMAKE_C_FLAGS "-Werror -Wdeclaration-after-statement -Wno-pointer-sign -Wall -Wmissing-prototypes -Wmissing-declarations -Wno-unused ${CMAKE_C_FLAGS}")
-- set( CMAKE_CXX_FLAGS "-Werror -Wall -Wmissing-declarations -Wno-unused -Wno-error=parentheses ${CMAKE_CXX_FLAGS}")
- set( CMAKE_C_FLAGS "-Wno-deprecated-declarations -std=gnu11 -Wno-error=parentheses ${CMAKE_C_FLAGS}")
-+ set( CMAKE_CXX_FLAGS "-Werror -Wall -Wmissing-declarations -Wno-unused -Wno-error=parentheses ${CMAKE_CXX_FLAGS}")
-+ set( CMAKE_CXX_FLAGS "-Wno-deprecated-declarations -Wno-register ${CMAKE_CXX_FLAGS}")
- set( CMAKE_C_FLAGS_RELEASE "-O3 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 ${CMAKE_C_FLAGS}")
- endif (UNIX)
- if (MINGW)
---- libgnucash/engine/CMakeLists.txt.orig
-+++ libgnucash/engine/CMakeLists.txt
-@@ -235,7 +235,6 @@ add_dependencies (gncmod-engine swig-runtime-h iso-4217-c)
- target_link_libraries(gncmod-engine gnc-core-utils gnc-module ${Boost_DATE_TIME_LIBRARIES} ${Boost_REGEX_LIBRARIES} ${REGEX_LDFLAGS} ${GMODULE_LDFLAGS} ${GLIB2_LDFLAGS} ${GOBJECT_LDFLAGS} ${GUILE_LDFLAGS})
-
- target_compile_definitions (gncmod-engine PRIVATE -DG_LOG_DOMAIN=\"gnc.engine\")
--target_compile_options (gncmod-engine PRIVATE -Wno-deprecated-register)
-
- target_include_directories (gncmod-engine
- PRIVATE ${CMAKE_CURRENT_BINARY_DIR} # for iso-4217-currencies.c
---
-2.19.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 2f308207ca86..2385afe4c030 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
pkgname=gnucash-xbt-minimal
_pkgname=gnucash
-pkgver=3.2
-pkgrel=2
+pkgver=5.5
+pkgrel=1
_sourcerel=
pkgdesc="A personal and small-business financial-accounting application with Bitcoin but without ofx/qfx import and aqbanking support"
-arch=(x86_64)
+arch=(x86_64 aarch64)
url="http://www.gnucash.org"
license=(GPL)
-depends=(webkit2gtk boost-libs guile libsecret)
-makedepends=(boost cmake gmock libdbi libdbi-drivers libmariadbclient postgresql-libs)
+depends=(webkit2gtk boost-libs libdbi libdbi-drivers guile libsecret)
+makedepends=(boost cmake gmock libmariadbclient postgresql-libs swig)
optdepends=(
'gnucash-docs: for documentation'
'iso-codes: for translation of currency names'
@@ -21,16 +21,14 @@ options=(!emptydirs)
conflicts=(gnucash gnucash-devel gnucash-xbt)
provides=(gnucash)
source=("https://github.com/Gnucash/${_pkgname}/releases/download/${pkgver}/${_pkgname}-${pkgver}${_sourcerel}.tar.bz2"
- "xbt.patch"
- "0001-Fix-compiler-warning-issues.patch")
-sha1sums=('4ab5baf0d7328e7b6f6a0cb0b4fea3864beb17dd'
- '52cf6820bf1dd87b5807997e49ec9c861ff516af'
- '2a206572b385288fd4a7dd9b2bedb2b793d4ca2b')
+ "xbt.patch")
+
+sha256sums=('b4daf67bb892b706323f62e9fa97242039d7dd0a2e1e10771e0c25817dd0ed3b'
+ '8cf12425a9f66c69473d83582742244889dc0ffb854d3a502aca58bc649878d4')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
patch -Np0 -i "${srcdir}/xbt.patch"
- patch -Np0 -i "${srcdir}/0001-Fix-compiler-warning-issues.patch"
cd "${srcdir}"
mkdir build
@@ -49,7 +47,7 @@ prepare() {
build() {
cd "${srcdir}/build"
- make
+ make -j 6
}
package() {