summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
-rw-r--r--gdl-template.patch20
3 files changed, 4 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9915e1f4e144..3692b9739e5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnudatalanguage
pkgdesc = An IDL (Interactive Data Language) compatible incremental compiler (ie. runs IDL programs)
pkgver = 0.9.6
- pkgrel = 3
+ pkgrel = 4
url = http://gnudatalanguage.sourceforge.net/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index aa5e27a60b6e..4f9ccdebbf9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=gnudatalanguage
pkgver=0.9.6
-pkgrel=3
+pkgrel=4
pkgdesc="An IDL (Interactive Data Language) compatible incremental compiler (ie. runs IDL programs)"
arch=('i686' 'x86_64')
url="http://gnudatalanguage.sourceforge.net/"
@@ -30,14 +30,11 @@ build() {
-DMAGICK=NO -DFFTW=YES -DHDF5=YES -DHDF=NO -DGRIB=YES -DUDUNITS=YES \
-DCMAKE_C_FLAGS="-I/usr/include/ImageMagick \
-I/usr/include/python2.7 \
- -I/usr/lib/python2.7/site-packages/numpy/core/include" ..\
- -DHDF5=NO
+ -I/usr/lib/python2.7/site-packages/numpy/core/include" ..
make
}
package() {
- cd $srcdir/gdl-${pkgver}/
- patch -p1 < ../../gdl-template.patch
- cd build
+ cd $srcdir/gdl-${pkgver}/build
make DESTDIR=$pkgdir install
install -D -m755 ../../gdl.profile $pkgdir/etc/profile.d/gdl.sh
diff --git a/gdl-template.patch b/gdl-template.patch
deleted file mode 100644
index 67610f194e82..000000000000
--- a/gdl-template.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -up gdl-0.9.6/src/specializations.hpp.gcc6 gdl-0.9.6/src/specializations.hpp
---- gdl-0.9.6/src/specializations.hpp.gcc6 2015-08-24 15:26:47.000000000 -0600
-+++ gdl-0.9.6/src/specializations.hpp 2016-03-03 16:30:46.694379312 -0700
-@@ -534,16 +534,6 @@ void Data_<SpDString>::MinMax( DLong* mi
-
- // default_io.cpp
- template<>
--std::istream& operator>>(std::istream& i, Data_<SpDFloat>& data_);
--template<>
--std::istream& operator>>(std::istream& i, Data_<SpDDouble>& data_);
--template<>
--std::istream& operator>>(std::istream& i, Data_<SpDComplex>& data_);
--template<>
--std::istream& operator>>(std::istream& i, Data_<SpDComplexDbl>& data_);
--template<>
--std::istream& operator>>(std::istream& is, Data_<SpDString>& data_);
--template<>
- std::ostream& Data_<SpDLong>::ToStream(std::ostream& o, SizeT w, SizeT* actPosPtr);
- template<>
- std::ostream& Data_<SpDULong>::ToStream(std::ostream& o, SizeT w, SizeT* actPosPtr);