summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rw-r--r--gnunet.install14
3 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06fa12d09a8b..21b935f0e88a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnunet
pkgdesc = A framework for secure peer-to-peer networking
pkgver = 0.15.3
- pkgrel = 7
+ pkgrel = 8
url = http://gnunet.org
install = gnunet.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 0532899de881..05fa9523bbe7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname='gnunet'
pkgver='0.15.3'
-pkgrel=7
+pkgrel=8
pkgdesc='A framework for secure peer-to-peer networking'
arch=('i686' 'x86_64')
url="http://${pkgname}.org"
@@ -97,8 +97,8 @@ package() {
install -Dm644 "${srcdir}/${pkgname}-uri.desktop" \
"${pkgdir}/usr/share/applications/${pkgname}-uri.desktop"
- install -dm755 "${pkgdir}/etc/skel/.config"
- install -Dm644 "${srcdir}/${pkgname}-user.conf" \
+ install -dm700 "${pkgdir}/etc/skel/.config"
+ install -Dm600 "${srcdir}/${pkgname}-user.conf" \
"${pkgdir}/etc/skel/.config/${pkgname}.conf"
# Automatically generate a configuration file using the content of
diff --git a/gnunet.install b/gnunet.install
index 195e63723ef8..26160eccc0b9 100644
--- a/gnunet.install
+++ b/gnunet.install
@@ -2,14 +2,18 @@ post_install() {
local _PWD_PAIRS_="$(awk -F ':' '$3>=1000 && $3<2000 {print $1":"$6}' '/etc/passwd')"
local _USER_
- local _CFG_FILE_
+ local _GROUP_
+ local _CFG_DIR_
for _PWD_PAIR_ in ${_PWD_PAIRS_}; do
_USER_="$(echo $_PWD_PAIR_ | cut -d ':' -f 1)"
- _CFG_FILE_="$(echo $_PWD_PAIR_ | cut -d ':' -f 2)/.config/gnunet.conf"
- test -e "${_CFG_FILE_}" || install -Dm644 -o "${_USER_}" -g \
- "$(id -gn "${_USER_}")" /etc/skel/.config/gnunet.conf \
- "${_CFG_FILE_}"
+ _GROUP_="$(id -gn "${_USER_}")"
+ _CFG_DIR_="$(echo $_PWD_PAIR_ | cut -d ':' -f 2)/.config"
+ test -e "${_CFG_DIR_}/gnunet.conf" || (install -dm700 -o \
+ "${_USER_}" -g "${_GROUP_}" "${_CFG_DIR_}" && install \
+ -Dm600 -o "${_USER_}" -g "${_GROUP_}" \
+ '/etc/skel/.config/gnunet.conf' \
+ "${_CFG_DIR_}/gnunet.conf")
done
echo