summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
-rw-r--r--gnunet-user.conf3
-rw-r--r--gnunet.install28
4 files changed, 43 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 982a4a475348..06fa12d09a8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = gnunet
pkgdesc = A framework for secure peer-to-peer networking
pkgver = 0.15.3
- pkgrel = 6
+ pkgrel = 7
url = http://gnunet.org
+ install = gnunet.install
arch = i686
arch = x86_64
license = AGPL
@@ -55,6 +56,7 @@ pkgbase = gnunet
source = gnunet.sysusers
source = gnunet.tmpfiles
source = gnunet-uri.desktop
+ source = gnunet-user.conf
source = gnunet-user.service
validpgpkeys = D8423BCB326C7907033929C7939E6BE1E29FC3CC
sha256sums = d62669a8f41e078eaa220ce77a32f4f3f801e3099357ae8c705498fe73884ec5
@@ -63,6 +65,7 @@ pkgbase = gnunet
sha256sums = 66299dbbdd0219d2f5f0520e69fc094f38f789724d973c2f63a421257ea4f755
sha256sums = 5c34e1ecc6208900426f8e399e8c3edbef12cce19eba605fd7364ddb3547d9f0
sha256sums = 98e4e1d6d4fd7c7fd05d9e16402c95f1e7afeb4b97c8c68ac63e8abd11ff4ee7
+ sha256sums = 3f17b9ed2c1f8cc0f919fe477df99678c17778a31f1eeb56517e285e3cef30f2
sha256sums = 60caee20b53bcc69522556b35ac3d35d89e28c49b9a22a2ed5121df4a2c33be5
pkgname = gnunet
diff --git a/PKGBUILD b/PKGBUILD
index eacf06fda92d..0532899de881 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname='gnunet'
pkgver='0.15.3'
-pkgrel=6
+pkgrel=7
pkgdesc='A framework for secure peer-to-peer networking'
arch=('i686' 'x86_64')
url="http://${pkgname}.org"
@@ -38,7 +38,9 @@ source=("ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"{,.sig}
"${pkgname}.sysusers"
"${pkgname}.tmpfiles"
"${pkgname}-uri.desktop"
+ "${pkgname}-user.conf"
"${pkgname}-user.service")
+install="${pkgname}.install"
validpgpkeys=('D8423BCB326C7907033929C7939E6BE1E29FC3CC')
sha256sums=('d62669a8f41e078eaa220ce77a32f4f3f801e3099357ae8c705498fe73884ec5'
'SKIP'
@@ -46,6 +48,7 @@ sha256sums=('d62669a8f41e078eaa220ce77a32f4f3f801e3099357ae8c705498fe73884ec5'
'66299dbbdd0219d2f5f0520e69fc094f38f789724d973c2f63a421257ea4f755'
'5c34e1ecc6208900426f8e399e8c3edbef12cce19eba605fd7364ddb3547d9f0'
'98e4e1d6d4fd7c7fd05d9e16402c95f1e7afeb4b97c8c68ac63e8abd11ff4ee7'
+ '3f17b9ed2c1f8cc0f919fe477df99678c17778a31f1eeb56517e285e3cef30f2'
'60caee20b53bcc69522556b35ac3d35d89e28c49b9a22a2ed5121df4a2c33be5')
@@ -94,6 +97,10 @@ package() {
install -Dm644 "${srcdir}/${pkgname}-uri.desktop" \
"${pkgdir}/usr/share/applications/${pkgname}-uri.desktop"
+ install -dm755 "${pkgdir}/etc/skel/.config"
+ install -Dm644 "${srcdir}/${pkgname}-user.conf" \
+ "${pkgdir}/etc/skel/.config/${pkgname}.conf"
+
# Automatically generate a configuration file using the content of
# `/usr/share/gnunet/config.d/` as model; in this way we can ensure
# that this configuration file is the one backed up with each update,
diff --git a/gnunet-user.conf b/gnunet-user.conf
new file mode 100644
index 000000000000..22f1fe37a82d
--- /dev/null
+++ b/gnunet-user.conf
@@ -0,0 +1,3 @@
+[arm]
+START_SYSTEM_SERVICES = NO
+START_USER_SERVICES = YES
diff --git a/gnunet.install b/gnunet.install
new file mode 100644
index 000000000000..7d6a2e3ffabd
--- /dev/null
+++ b/gnunet.install
@@ -0,0 +1,28 @@
+post_install() {
+
+ local _PWD_PAIRS_="$(awk -F ':' '$3>=1000 && $3<2000 {print $1":"$6}' '/etc/passwd')"
+ local _USER_
+ local _CFG_FILE_
+
+ for _PWD_PAIR_ in ${_PWD_PAIRS_}; do
+ _USER_="$(echo $_PWD_PAIR_ | cut -d ':' -f 1)"
+ _CFG_FILE_="$(echo $_PWD_PAIR_ | cut -d ':' -f 2)/.config/gnunet.conf"
+ test -e "${_CFG_FILE_}" || install -Dm644 -o "${_USER_}" -g \
+ "$(id -gn "${_USER_}")" /etc/skel/.config/gnunet.conf \
+ "${_CFG_FILE_}"
+ done
+
+ echo
+ echo 'Do not forget to add your user to the `gnunet` group, with'
+ echo
+ echo ' sudo usermod -aG gnunet YOUR-USERNAME'
+ echo
+ echo 'If later you want to remove your user from the group, launch:'
+ echo
+ echo ' sudo gpasswd --delete YOUR-USERNAME gnunet'
+ echo
+ echo 'For information on how to use GNUnet plaese refer to the GNUnet article in the'
+ echo 'ArchWiki (https://wiki.archlinux.org/title/GNUnet).'
+ echo
+
+}