summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1755db371152
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gnunet-python-git
+ pkgdesc = Python bindings for GNUnet
+ pkgver = r44.a3707a2
+ pkgrel = 1
+ url = http://gnunet.org
+ arch = i686
+ arch = x86_64
+ license = AGPL3
+ depends = gnunet
+ depends = python
+ provides = gnunet-python
+ conflicts = gnunet-python
+ conflicts = gnunet-python-bin
+ source = git+https://gnunet.org/git/gnunet-python.git
+ sha256sums = SKIP
+
+pkgname = gnunet-python-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..683cb4e7363f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: grufo <madmurphy333 AT gmail DOT com>
+
+_appname='gnunet'
+_modname="${_appname}-python"
+pkgname="${_modname}-git"
+pkgver='r44.a3707a2'
+pkgrel=1
+pkgdesc='Python bindings for GNUnet'
+arch=('i686' 'x86_64')
+url="http://${_appname}.org"
+license=('AGPL3')
+conflicts=("${_modname}" "${_modname}-bin")
+provides=("${_modname}")
+depends=("${_appname}" 'python')
+source=("git+https://${_appname}.org/git/${_modname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_modname}"
+ printf "'r%s.%s'" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_modname}"
+ python setup.py install --root="${pkgdir}"
+}
+