summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD40
-rw-r--r--go-for-it.install16
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cdb4dcf735aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Thu Dec 17 00:34:56 UTC 2015
+pkgbase = go-for-it
+ pkgdesc = A stylish to-do list with built-in productivity timer.
+ pkgver = 1.4
+ pkgrel = 1
+ url = https://github.com/mank319/Go-For-It
+ install = go-for-it.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = vala
+ makedepends = cmake
+ depends = gtk3
+ depends = libnotify
+ conflicts = go-for-it-git
+ conflicts = go-for-it-bzr
+ source = https://github.com/mank319/Go-For-It/archive/release_v1.4.tar.gz
+ sha256sums = 76201c6c047f8d3e3f86d0a607b4e2f0f723007e7ed3a0f778bcf3fe0e39c85b
+
+pkgname = go-for-it
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8185fe4b0ec4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Quentin Retornaz <quentin dot retornaz at yahoo dot fr>
+# Contributor: Manuel Kehl <https://launchpad.net/~mank319, https://github.com/mank319/>
+
+pkgname=go-for-it
+pkgver=1.4
+pkgrel=1
+pkgdesc='A stylish to-do list with built-in productivity timer.'
+arch=('i686' 'x86_64')
+url='https://github.com/mank319/Go-For-It'
+license=('GPL3')
+depends=('gtk3' 'libnotify')
+optdepends=()
+makedepends=('vala' 'cmake')
+conflicts=('go-for-it-git' 'go-for-it-bzr')
+install=go-for-it.install
+source=(https://github.com/mank319/Go-For-It/archive/release_v1.4.tar.gz)
+sha256sums=('76201c6c047f8d3e3f86d0a607b4e2f0f723007e7ed3a0f778bcf3fe0e39c85b')
+
+prepare() {
+ mv ${srcdir}/Go-For-It-release_v${pkgver}/* ${srcdir}/
+}
+
+build() {
+ cd ${srcdir}
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build && cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: \ No newline at end of file
diff --git a/go-for-it.install b/go-for-it.install
new file mode 100644
index 000000000000..826f632e9bfa
--- /dev/null
+++ b/go-for-it.install
@@ -0,0 +1,16 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -ftq usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -ftq usr/share/icons/hicolor
+}
+
+post_remove() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -ftq usr/share/icons/hicolor
+}
+
+# vim: ts=2 sw=2 et: \ No newline at end of file