summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1e3d0f2e2aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Fri Mar 4 10:58:52 UTC 2016
+pkgbase = go-gojsonschema
+ pkgdesc = Go implementation of JSON Schema, based on IETF's draft v4
+ pkgver = 349.3988ac1
+ pkgrel = 1
+ url = https://github.com/xeipuuv/gojsonschema
+ arch = x86_64
+ arch = i686
+ license = Apache
+ makedepends = rsync
+ depends = go
+ options = !strip
+ options = !emptydirs
+
+pkgname = go-gojsonschema
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea8ed9152871
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Sven Schneider <archlinux.sandmann@googlemail.com>
+
+pkgname=go-gojsonschema
+pkgver=349.3988ac1
+pkgrel=1
+pkgdesc="Go implementation of JSON Schema, based on IETF's draft v4"
+arch=('x86_64' 'i686')
+url="https://github.com/xeipuuv/gojsonschema"
+license=('Apache')
+depends=('go')
+makedepends=('rsync')
+options=('!strip' '!emptydirs')
+_gourl='github.com/xeipuuv/gojsonschema'
+
+build() {
+ GOPATH="${srcdir}" go get -v -x ${_gourl}
+}
+
+package() {
+ cd "${srcdir}"
+
+ mkdir -p "${pkgdir}/usr/lib/go"
+ rsync -avz --exclude .git {src,pkg} "${pkgdir}/usr/lib/go"
+}