summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD35
2 files changed, 14 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0e933d8eb92..dbc6ebc871d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = go-gpm
pkgdesc = Barebones dependency manager for Go.
- pkgver = 1.3.2.r10.g7db809e
- pkgrel = 1
+ pkgver = 1.4.0
+ pkgrel = 2
url = https://github.com/pote/gpm
arch = any
license = MIT
- makedepends = git
depends = go
- source = go-gpm::git+https://github.com/pote/gpm.git
- md5sums = SKIP
+ source = gpm-1.4.0.tar.gz::https://github.com/pote/gpm/archive/v1.4.0.tar.gz
+ sha256sums = 2e213abbb1a12ecb895c3f02b74077d3440b7ae3221b4b524659c2ea9065b02a
pkgname = go-gpm
diff --git a/PKGBUILD b/PKGBUILD
index c8121b149542..2eeaaa226396 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,24 @@
-# Maintainer: philanecros <philanecros@gmail.com>
+# Maintainer: Pierce Lopez <pierce.lopez@gmail.com>
pkgname=go-gpm
-pkgver=1.3.2.r10.g7db809e
-pkgrel=1
+pkgver=1.4.0
+pkgrel=2
pkgdesc="Barebones dependency manager for Go."
arch=("any")
url="https://github.com/pote/gpm"
license=('MIT')
-groups=()
depends=("go")
-makedepends=('git')
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-source=("$pkgname::git+https://github.com/pote/gpm.git")
-md5sums=('SKIP')
-noextract=()
-
-pkgver() {
- cd "$pkgname"
- # cutting off 'v' prefix that presents in the git tag
- git describe --tags --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
-}
+source=("gpm-${pkgver}.tar.gz::https://github.com/pote/gpm/archive/v${pkgver}.tar.gz")
+sha256sums=('2e213abbb1a12ecb895c3f02b74077d3440b7ae3221b4b524659c2ea9065b02a')
build() {
- cd "$srcdir/${pkgname}"
- ./configure --prefix=/usr
+ cd gpm-$pkgver
+ # avoid conflict with existing core/gpm package
+ ./configure --prefix=/usr --exec=go-gpm
make
}
package() {
- cd "$srcdir/${pkgname}"
- # avoid conflict with existing core/gpm package
- make DESTDIR="$pkgdir/" exec="go-gpm" install
+ cd gpm-$pkgver
+ make DESTDIR="$pkgdir" install
}