summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD15
3 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df6c77ea053e..84899c28534a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = go-kbdgrab
pkgdesc = Key grabber written in golang for cleaning your keyboard
- pkgver = r19.c8fbdeb
+ pkgver = r22.e829367
pkgrel = 1
url = https://github.com/tonylambiris/go-kbdgrab
arch = i686
arch = x86_64
license = BSD
makedepends = go
- makedepends = go-bindata-new-git
- source = git+https://github.com/tonylambiris/go-kbdgrab.git
- md5sums = SKIP
+ source = git+https://github.com/tonylambiris/go-kbdgrab
+ sha256sums = SKIP
pkgname = go-kbdgrab
diff --git a/.gitignore b/.gitignore
index da0fe6457f94..f990186b4746 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ src
pkg
go-kbdgrab
*pkg.tar.xz
+tags
diff --git a/PKGBUILD b/PKGBUILD
index a6ccf151bd68..a60bc08085e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=go-kbdgrab
-pkgver=r19.c8fbdeb
+pkgver=r22.e829367
pkgrel=1
pkgdesc='Key grabber written in golang for cleaning your keyboard'
arch=(i686 x86_64)
url='https://github.com/tonylambiris/go-kbdgrab'
license=(BSD)
-makedepends=(go go-bindata-new-git)
-source=("git+https://github.com/tonylambiris/go-kbdgrab.git")
-md5sums=('SKIP')
+makedepends=(go)
+source=("git+https://github.com/tonylambiris/go-kbdgrab")
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname}"
@@ -17,18 +17,19 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-
prepare() {
cd "${srcdir}/${pkgname}"
install -m755 -d "${srcdir}/go/src/github.com/tonylambiris/"
- cp -a "${srcdir}/${pkgname}" "${srcdir}/go/src/github.com/tonylambiris/"
+ ln -sf "${srcdir}/${pkgname}" "${srcdir}/go/src/github.com/tonylambiris/go-kbdgrab"
}
build() {
cd "${srcdir}/go/src/github.com/tonylambiris/go-kbdgrab"
- GOROOT="/usr/lib/go" GOPATH="${srcdir}/go" PATH="$PATH:$GOPATH/bin" make
+ export GOPATH="${srcdir}/go"
+ export PATH="${PATH}:${GOPATH}/bin"
+ make
}
package() {