summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD34
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2d48b993bac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Jan 28 17:48:18 UTC 2018
+pkgbase = go-langserver-git
+ pkgdesc = go-langserver is a Go language server that speaks Language Server Protocol. It supports editor features such as go-to-definition, hover, and find-references for Go projects.
+ pkgver = v1.0.0.r287.g73491f4
+ pkgrel = 1
+ url = https://github.com/sourcegraph/go-langserver
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = go
+ provides = go-langserver
+ conflicts = go-langserver
+ options = !strip
+ options = !emptydirs
+ source = go-langserver-git::git://github.com/sourcegraph/go-langserver.git
+ md5sums = SKIP
+
+pkgname = go-langserver-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0f774fa1349d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.pkg.tar.xz
+go-langserver-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5dc2a1b255ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Timofey TItovets <nefelim4ag@gmail.com>
+
+_pkgname=go-langserver
+pkgname=$_pkgname-git
+pkgver=v1.0.0.r287.g73491f4
+pkgrel=1
+pkgdesc="go-langserver is a Go language server that speaks Language Server Protocol. It supports editor features such as go-to-definition, hover, and find-references for Go projects."
+arch=('any')
+url="https://github.com/sourcegraph/go-langserver"
+license=('MIT')
+makedepends=('git' 'go')
+provides=($_pkgname)
+conflicts=($_pkgname)
+options=('!strip' '!emptydirs')
+source=($pkgname::git://github.com/sourcegraph/go-langserver.git)
+md5sums=('SKIP')
+
+_gourl=github.com/sourcegraph/go-langserver
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ mkdir -p "$srcdir/build/src/github.com/sourcegraph/"
+ cp -a ./${pkgname} "$srcdir/build/src/github.com/sourcegraph/${pkgname}"
+ GOPATH="$srcdir/build" go get -v -u $_gourl
+}
+
+package() {
+ cd build
+ install -Dm755 bin/go-langserver "$pkgdir/usr/bin/go-langserver"
+}