summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD3
-rw-r--r--go-livepeer.install20
4 files changed, 23 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f420d9ed364f..e7f8a22ab3af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,6 +3,7 @@ pkgbase = go-livepeer-bin
pkgver = 0.5.21
pkgrel = 1
url = https://github.com/livepeer/go-livepeer
+ install = go-livepeer.install
arch = x86_64
license = MIT
provides = go-livepeer
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 3af70b1f10e2..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,21 +0,0 @@
-MIT License
-
-Copyright (c) 2017 Livepeer
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in all
-copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index a8c46bdf5eab..7b98680b6119 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,6 +8,7 @@ pkgdesc='Official Go binaries of the Livepeer protocol'
arch=('x86_64')
url='https://github.com/livepeer/go-livepeer'
license=('MIT')
+install=${_pkgname}.install
backup=('etc/go-livepeer/environment')
conflicts=('go-livepeer')
provides=('go-livepeer' 'go-livepeer-bin')
@@ -22,7 +23,7 @@ sha256sums=('aa966e0af5599faf04d1c9334da36f59e3f6007ca23fc0f21c7c2379b998f0e4'
package() {
install -Dm 644 "${srcdir}/environment" -t "${pkgdir}/etc/${_pkgname}"
install -Dm 644 "${srcdir}/livepeer.service" -t "${pkgdir}/usr/lib/systemd/system"
- install -Dm 644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
install -Dm 755 "${srcdir}/livepeer-linux-amd64/livepeer" "${pkgdir}/usr/bin/livepeer"
install -Dm 755 "${srcdir}/livepeer-linux-amd64/livepeer_cli" "${pkgdir}/usr/bin/livepeer_cli"
install -Dm 755 "${srcdir}/livepeer-linux-amd64/livepeer_bench" "${pkgdir}/usr/bin/livepeer_bench"
diff --git a/go-livepeer.install b/go-livepeer.install
new file mode 100644
index 000000000000..ac207f85ff76
--- /dev/null
+++ b/go-livepeer.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo -e "####################################################"
+ echo -e "## Before first start, you must edit the systemd ##"
+ echo -e "## environment file with your orchestrator's info ##"
+ echo -e "## /etc/go-livepeer/environment ##"
+ echo -e "## ##"
+ echo -e "## Update these values with your own and then run ##"
+ echo -e "## sudo systemctl daemon-reload ##"
+ echo -e "## sudo systemctl enable --now ##"
+ echo -e "## ##"
+ echo -e "## Support may be found at Livepeer's official ##"
+ echo -e "## community channels on their forum & Discord - ##"
+ echo -e "## https://discord.gguaPhtyrWsF ##"
+ echo -e "## https://forum.livepeer.org ##"
+ echo -e "####################################################"
+}
+
+post_upgrade() {
+ post_install
+}