summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4abd02ba8a04..501177996f1d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Feb 9 09:35:43 UTC 2018
+# Fri Feb 9 10:05:36 UTC 2018
pkgbase = go4
pkgdesc = Object-oriented system (GSI Object Oriented On-line Off-line system) based on ROOT
pkgver = 5.2.0
diff --git a/PKGBUILD b/PKGBUILD
index c98326904249..6d6dea898172 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,6 +2,7 @@
#
# Note to self. It is necessary to remove the current Go4 installation -if any- otherwise the compilation fails.
# Also, after removal, use a fresh terminal as go4login variables are no longer valid
+# Maybe just unsetting GO4SYS is enough(?)
#
# It looks that ROOT6 requires the modification/definition of the variable ROOT_INCLUDE_PATH to /usr/include/go4
#
@@ -21,6 +22,8 @@ _USEQT=4 # qt4 - Qt 4.6.x and higher (recommended) <-- from the source code 5.1.
prepare() {
+ unset GO4SYS
+
cd go4-${pkgver}
# make it installation friendly
@@ -77,10 +80,10 @@ package() {
source /usr/bin/go4login
# If ROOT_INCLUDE_PATH already exists, then add Go4 to it, otherwise do nothing
- export ROOT_INCLUDE_PATH=${ROOT_INCLUDE_PATH:+$ROOT_INCLUDE_PATH:/usr/include/go4}
+ export ROOT_INCLUDE_PATH=\${ROOT_INCLUDE_PATH:+\$ROOT_INCLUDE_PATH:/usr/include/go4}
# if ROOT_INCLUDE_PATH does not exist, define it as the one from Go4, otherwise do nothing
- export ROOT_INCLUDE_PATH=${ROOT_INCLUDE_PATH:-/usr/include/go4}
+ export ROOT_INCLUDE_PATH=\${ROOT_INCLUDE_PATH:-/usr/include/go4}
EOF