summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--Makefile.config.patch29
-rw-r--r--PKGBUILD27
3 files changed, 51 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 574a71c05f3a..def3eae9d232 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
# Generated by mksrcinfo v8
-# Wed Oct 9 13:22:41 UTC 2019
+# Fri Nov 22 17:43:41 UTC 2019
pkgbase = go4
pkgdesc = Object-oriented system (GSI Object Oriented On-line Off-line system) based on ROOT
- pkgver = 5.3.2
- pkgrel = 3
+ pkgver = 6.0.0
+ pkgrel = 1
url = https://www.gsi.de/en/work/research/experiment_electronics/data_processing/data_analysis/the_go4_home_page.htm
arch = x86_64
license = GPL
depends = root
depends = qt5-base
- source = http://web-docs.gsi.de/~go4/download/go4-5.3.2.tar.gz
- sha256sums = eca243e519bf5903fee8e47f9fdbab0713075d4eb2ea14eb805946938cb544bf
+ source = http://web-docs.gsi.de/~go4/download/go4-6.0.0.tar.gz
+ source = Makefile.config.patch
+ sha256sums = 28e3ecccbbde5a9168e85d6b6b5abaa147c0d65ea70332cdaaa80050ad61c55f
+ sha256sums = d03fd394378e4ee97d2d17071010df046f1e9346d7b57585a694410a25bc5883
pkgname = go4
diff --git a/Makefile.config.patch b/Makefile.config.patch
new file mode 100644
index 000000000000..dfbae65bfa74
--- /dev/null
+++ b/Makefile.config.patch
@@ -0,0 +1,29 @@
+--- src/go4-6.0.0/Makefile.config 2019-10-25 12:45:46.709957747 +0200
++++ Makefile.config 2019-11-22 18:15:33.517213237 +0100
+@@ -130,7 +130,7 @@
+
+ QMAKEOPTFLAG = "CONFIG+=release"
+
+-QMAKEFLAGS = "QMAKE_CXXFLAGS=$(WARNINGS) $(QTGO4DEFINITIONS)" "QMAKE_CXXFLAGS_RELEASE = -O2" "QMAKE_CFLAGS_RELEASE = -O2"
++QMAKEFLAGS = "QMAKE_CXXFLAGS=$(WARNINGS) $(QTGO4DEFINITIONS) -std=c++17" "QMAKE_CXXFLAGS_RELEASE = -O2" "QMAKE_CFLAGS_RELEASE = -O2"
+
+ ifeq ($(GO4_OS),Win32)
+ QMAKEFLAGS += "INCLUDEPATH+=$(shell cygpath -w $(ROOTINCPATH))" "DEPENDPATH+=$(shell cygpath -w $(ROOTINCPATH))"
+@@ -277,7 +277,7 @@
+ -lMinuit \
+ $(if $(USESPECTRUM),-lSpectrum,) \
+ $(if $(USEXMLIO),-lXMLIO,) \
+- -L$(GO4LIBPATH)
++ -Llib
+
+ ifneq ($(USERT),false)
+ LIBS_BASESET += -lrt
+@@ -296,7 +296,7 @@
+ $(if $(USEDIM),-L$(DIMLIBPATH) -ldim,) \
+ $(if $(LINKX11),-L/usr/X11R6/lib/ -lX11,) \
+ $(if $(GO4_X11),-L/usr/lib/ -lX11,) \
+- -L$(GO4LIBPATH) \
++ -L../../lib \
+ $(call go4ldname,Go4Fit) \
+ $(call go4ldname,Go4Base) \
+ $(call go4ldname,Go4ThreadManager) \
diff --git a/PKGBUILD b/PKGBUILD
index 7e18572f80eb..9f74658e790b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,17 @@
#
pkgname=go4
_Pkgname=Go4
-pkgver=5.3.2
-pkgrel=3
+pkgver=6.0.0
+pkgrel=1
pkgdesc='Object-oriented system (GSI Object Oriented On-line Off-line system) based on ROOT'
arch=('x86_64')
depends=('root' 'qt5-base')
url="https://www.gsi.de/en/work/research/experiment_electronics/data_processing/data_analysis/the_go4_home_page.htm"
license=('GPL')
-source=("http://web-docs.gsi.de/~go4/download/go4-${pkgver}.tar.gz")
-sha256sums=('eca243e519bf5903fee8e47f9fdbab0713075d4eb2ea14eb805946938cb544bf')
+source=("http://web-docs.gsi.de/~go4/download/go4-${pkgver}.tar.gz"
+ "Makefile.config.patch")
+sha256sums=('28e3ecccbbde5a9168e85d6b6b5abaa147c0d65ea70332cdaaa80050ad61c55f'
+ 'd03fd394378e4ee97d2d17071010df046f1e9346d7b57585a694410a25bc5883')
prepare() {
@@ -25,12 +27,9 @@ prepare() {
sed -i 's#\$(GO4LIBPATH)#$(DESTDIR)/&#g' Makefile
sed -i 's#\$(GO4TOPPATH)#$(DESTDIR)/&#g' Makefile
- sed -i 's#QMAKE_CXXFLAGS=#& -std=c++17#g' Makefile.config
+ # something change and the libraries are not found now at compilation time
+ patch -Np2 < ${srcdir}/Makefile.config.patch
- # The line INCPATH in src/go4-5.3.2/qt4/Go4UserGUI/Makefile.qt does
- # not include respect USERGUI4_QFLAGS = GO4INCDIR=../../include
- cp ./qt4/Go4GUI/QGo4Widget.h ./qt4/Go4UserGUI/
- cp ./qt4/Go4QtRoot/QRootCanvas.h ./qt4/Go4UserGUI/
}
build() {
@@ -39,9 +38,6 @@ build() {
make clean-bin
make clean
- ##
- # rpath=false seemed to reduce que volume of warnings with ROOT6
- ##
make prefix=/usr \
withqt=5 \
GO4_OS=Linux \
@@ -51,6 +47,13 @@ build() {
nodepend=1 \
all || return 1
+ ## options not explored
+ # noweb=1
+ # nox11=1
+
+ # options known not to work Nov/22/2019
+ # designer=1
+
}
package() {