summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26f447a69d76..4abd02ba8a04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
# Generated by mksrcinfo v8
-# Thu Feb 8 14:23:19 UTC 2018
+# Fri Feb 9 09:35:43 UTC 2018
pkgbase = go4
pkgdesc = Object-oriented system (GSI Object Oriented On-line Off-line system) based on ROOT
pkgver = 5.2.0
- pkgrel = 6
+ pkgrel = 7
url = https://www.gsi.de/en/work/research/electronics/data_processing/data_analysis/the_go4_home_page.htm
- arch = i686
arch = x86_64
license = GPL
- depends = root=6.10.08
+ depends = root
depends = qt4
source = http://web-docs.gsi.de/~go4/download/go4-5.2.0.tar.gz
md5sums = eede668b446e899da12487f182957ed0
diff --git a/PKGBUILD b/PKGBUILD
index 3661a4c3cc5a..c98326904249 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,10 +8,10 @@
pkgname=go4
_Pkgname=Go4
pkgver=5.2.0
-pkgrel=6
+pkgrel=7
pkgdesc='Object-oriented system (GSI Object Oriented On-line Off-line system) based on ROOT'
-arch=('i686' 'x86_64')
-depends=('root=6.10.08' 'qt4')
+arch=('x86_64')
+depends=('root' 'qt4')
url="https://www.gsi.de/en/work/research/electronics/data_processing/data_analysis/the_go4_home_page.htm"
license=('GPL')
source=("http://web-docs.gsi.de/~go4/download/go4-${pkgver}.tar.gz")
@@ -33,6 +33,9 @@ prepare() {
#msg "fixing QGo4Widget.cpp:324:25: error: cannot convert ‘bool’ to ‘TGo4ViewPanel*’ in initialization"
#sed -i 's#TGo4ViewPanel\* res = false;#TGo4ViewPanel\* res = 0;#g' qt4/Go4GUI/QGo4Widget.cpp
+ msg "Fixing lack of Riosfwd.h from ROOT 6.12"
+ sed -i 's/#include "Riosfwd.h"/#include <iosfwd>/g' Go4EventServer/TGo4MbsFile.cxx
+
}
build() {
@@ -88,4 +91,8 @@ EOF
# for later maybe? uninstall and therefore remove packages
# PATH="${PATH/\/path\/to\/remove/}"
+ #/usr/include/root/Riosfwd.h:25:2: warning:
+ #warning "Riosfwd.h is deprecated. It will be removed in ROOT v6.12. Please use #include <iosfwd>, instead."
+
+ #sed -i 's#\$HOME#/usr#g' go
}