summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b578369b7c5f..a50ef221c7a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Aug 1 13:56:02 UTC 2016
+# Wed Nov 2 09:01:22 UTC 2016
pkgbase = go4
pkgdesc = Object-oriented system (GSI Object Oriented On-line Off-line system) based on ROOT
pkgver = 5.1.2
@@ -8,7 +8,7 @@ pkgbase = go4
arch = i686
arch = x86_64
license = GPL
- depends = root
+ depends = root5
depends = qt4
source = http://web-docs.gsi.de/~go4/download/go4-5.1.2.tar.gz
md5sums = 8083fe20cf894225039c4347de828f73
diff --git a/PKGBUILD b/PKGBUILD
index 8a3a0b137602..4d114861adcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,17 +8,17 @@ pkgver=5.1.2
pkgrel=1
pkgdesc='Object-oriented system (GSI Object Oriented On-line Off-line system) based on ROOT'
arch=('i686' 'x86_64')
-depends=('root' 'qt4')
+depends=('root5' 'qt4')
url="https://www.gsi.de/en/work/fairgsi/rare_isotope_beams/electronics/data_processing/data_analysis/the_go4_home_page.htm"
license=('GPL')
-source=("http://web-docs.gsi.de/~go4/download/${pkgname}-${pkgver}.tar.gz")
+source=("http://web-docs.gsi.de/~go4/download/go4-${pkgver}.tar.gz")
md5sums=('8083fe20cf894225039c4347de828f73')
-_USEQT=4
+_USEQT=4 # qt4 - Qt 4.6.x and higher (recommended) <-- from the source code 5.1.2
prepare() {
- cd ${pkgname}-${pkgver}
+ cd go4-${pkgver}
# make it installation friendly
sed -i 's#\$(GO4EXEPATH)#$(DESTDIR)/&#g' Makefile
@@ -33,28 +33,28 @@ prepare() {
build() {
- cd ${pkgname}-${pkgver}
+ cd go4-${pkgver}
make clean-bin
make clean
- make -j1 prefix=/usr withqt=$_USEQT GO4_OS=Linux rpath=true withdabc=no nodepend=1 debug=1 all || return 1
+ make prefix=/usr withqt=$_USEQT GO4_OS=Linux rpath=true withdabc=no nodepend=0 debug=1 all || return 1
}
package() {
#install the package
- cd ${pkgname}-${pkgver}
+ cd go4-${pkgver}
make DESTDIR=${pkgdir} install
#install the license
- install -Dm644 "${srcdir}/${pkgname}-${pkgver}/Go4License.txt" "$pkgdir/usr/share/licenses/${pkgname}/Go4License.txt"
+ install -Dm644 "${srcdir}/go4-${pkgver}/Go4License.txt" "$pkgdir/usr/share/licenses/go4/Go4License.txt"
#install the desktop file
echo "
[Desktop Entry]
Name=${_PKGNAME}
Comment=${pkgdesc}
- Exec=${pkgname}
+ Exec=go4
Icon=xchm-32
Terminal=false
Type=Application