summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD48
2 files changed, 29 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af8ec8a0be80..3c7bba738464 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,9 @@
pkgbase = gobject-introspection-git
- pkgdesc = Introspection system for GObject-based libraries (Git)
- pkgver = 1.64.0+47+ge7c17469
- pkgrel = 2
- epoch = 1
+ pkgdesc = Introspection system for GObject-based libraries
+ pkgver = 1.64.0+75+g8b0a7f4c
+ pkgrel = 1
url = https://wiki.gnome.org/Projects/GObjectIntrospection
arch = x86_64
- arch = i686
license = LGPL
license = GPL
makedepends = cairo
@@ -13,18 +11,14 @@ pkgbase = gobject-introspection-git
makedepends = gtk-doc
makedepends = python-sphinx
makedepends = meson
+ makedepends = glib2
depends = python-mako
depends = python-markdown
- provides = gobject-introspection=1.64.0+47+ge7c17469
- provides = gobject-introspection-runtime=1.64.0+47+ge7c17469
+ provides = gobject-introspection=1.64.0+75+g8b0a7f4c
conflicts = gobject-introspection
- conflicts = gobject-introspection-svn
- conflicts = gobject-introspection-runtime
- replaces = gobject-introspection-svn
- replaces = gobject-introspection
options = !emptydirs
source = git+https://gitlab.gnome.org/GNOME/gobject-introspection.git
- source = git+https://gitlab.gnome.org/GNOME/glib.git?signed#tag=2.64.1
+ source = git+https://gitlab.gnome.org/GNOME/glib.git
validpgpkeys = 923B7025EE03C1C59F42684CF0942E894B2EAFA0
sha512sums = SKIP
sha512sums = SKIP
@@ -32,12 +26,12 @@ pkgbase = gobject-introspection-git
pkgname = gobject-introspection-git
depends = python-mako
depends = python-markdown
- depends = gobject-introspection-runtime-git=1.64.0+47+ge7c17469-2
+ depends = gobject-introspection-runtime
pkgname = gobject-introspection-runtime-git
- pkgdesc = Introspection system for GObject-based libraries (Git) (runtime library)
+ pkgdesc = Introspection system for GObject-based libraries (runtime library)
depends = glib2
- provides = gobject-introspection=1.64.0+47+ge7c17469
- provides = gobject-introspection-runtime=1.64.0+47+ge7c17469
+ provides = gobject-introspection-runtime=1.64.0+75+g8b0a7f4c
provides = libgirepository-1.0.so
+ conflicts = gobject-introspection-runtime
diff --git a/PKGBUILD b/PKGBUILD
index 888455b1c822..015152021bd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,43 @@
-# Maintainer:
-# Contributor: Felix Golatofski <contact@xdfr.de>
-# Contributor: Joao Cordeiro <jlcordeiro at gmail dot com>
-# Contributor: <arsenm2@rpi.edu>
-# Contributor: Lubosz Sarnecki <lubosz@gmail.com>
-
+pkgbase=gobject-introspection-git
_pkgname=gobject-introspection
-pkgbase="${_pkgname}-git"
-pkgname=(${_pkgname}-git ${_pkgname}-runtime-git)
-pkgver=1.64.0+47+ge7c17469
-pkgrel=2
-epoch=1
-pkgdesc="Introspection system for GObject-based libraries (Git)"
+pkgname=(gobject-introspection-git gobject-introspection-runtime-git)
+pkgver=1.64.0+75+g8b0a7f4c
+pkgrel=1
+pkgdesc="Introspection system for GObject-based libraries"
url="https://wiki.gnome.org/Projects/GObjectIntrospection"
-arch=('x86_64' 'i686')
-license=('LGPL' 'GPL')
+arch=(x86_64)
+license=(LGPL GPL)
depends=(python-mako python-markdown)
-_glibver=2.64.1
-makedepends=(cairo git gtk-doc python-sphinx meson)
-provides=("gobject-introspection=${pkgver}" "gobject-introspection-runtime=${pkgver}")
-conflicts=('gobject-introspection' 'gobject-introspection-svn' "gobject-introspection-runtime")
-replaces=('gobject-introspection-svn' 'gobject-introspection')
+makedepends=(cairo git gtk-doc python-sphinx meson glib2)
+provides=(gobject-introspection=$pkgver)
+conflicts=(gobject-introspection)
options=(!emptydirs)
source=("git+https://gitlab.gnome.org/GNOME/gobject-introspection.git"
- "git+https://gitlab.gnome.org/GNOME/glib.git?signed#tag=$_glibver")
+ "git+https://gitlab.gnome.org/GNOME/glib.git")
sha512sums=('SKIP'
'SKIP')
validpgpkeys=('923B7025EE03C1C59F42684CF0942E894B2EAFA0') # Philip Withnall <philip@tecnocode.co.uk>
-
pkgver() {
- cd $srcdir/$_pkgname
+ cd $_pkgname
git describe --tags | sed 's/-/+/g'
}
-
+
build() {
- cd "$srcdir/$_pkgname"
- arch-meson $srcdir/$_pkgname build \
+ arch-meson $_pkgname build \
-D gtk_doc=true \
-D glib_src_dir="$srcdir/glib"
ninja -C build
}
check() {
- meson test -C $srcdir/$_pkgname/build
+ meson test -C build
}
package_gobject-introspection-git() {
- depends+=("gobject-introspection-runtime-git=$pkgver-$pkgrel")
+ depends+=("gobject-introspection-runtime")
- DESTDIR="$pkgdir" meson install -C $srcdir/$_pkgname/build
+ DESTDIR="$pkgdir" meson install -C build
python -m compileall -d /usr/lib/$_pkgname "$pkgdir/usr/lib/$_pkgname"
python -O -m compileall -d /usr/lib/$_pkgname "$pkgdir/usr/lib/$_pkgname"
@@ -61,7 +50,8 @@ package_gobject-introspection-git() {
package_gobject-introspection-runtime-git() {
pkgdesc+=" (runtime library)"
depends=(glib2)
- provides+=(libgirepository-1.0.so)
+ provides=(gobject-introspection-runtime=$pkgver libgirepository-1.0.so)
+ conflicts=(gobject-introspection-runtime)
mv "$srcdir/runtime" "$pkgdir/usr"
}