summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59fb46f4e98a..af8ec8a0be80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gobject-introspection-git
pkgdesc = Introspection system for GObject-based libraries (Git)
pkgver = 1.64.0+47+ge7c17469
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://wiki.gnome.org/Projects/GObjectIntrospection
arch = x86_64
@@ -32,7 +32,7 @@ pkgbase = gobject-introspection-git
pkgname = gobject-introspection-git
depends = python-mako
depends = python-markdown
- depends = gobject-introspection-runtime-git=1.64.0+47+ge7c17469-1
+ depends = gobject-introspection-runtime-git=1.64.0+47+ge7c17469-2
pkgname = gobject-introspection-runtime-git
pkgdesc = Introspection system for GObject-based libraries (Git) (runtime library)
diff --git a/PKGBUILD b/PKGBUILD
index 50e188796a6b..888455b1c822 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ _pkgname=gobject-introspection
pkgbase="${_pkgname}-git"
pkgname=(${_pkgname}-git ${_pkgname}-runtime-git)
pkgver=1.64.0+47+ge7c17469
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Introspection system for GObject-based libraries (Git)"
url="https://wiki.gnome.org/Projects/GObjectIntrospection"
@@ -35,20 +35,20 @@ pkgver() {
build() {
cd "$srcdir/$_pkgname"
- arch-meson $_pkgname build \
+ arch-meson $srcdir/$_pkgname build \
-D gtk_doc=true \
-D glib_src_dir="$srcdir/glib"
ninja -C build
}
check() {
- meson test -C build
+ meson test -C $srcdir/$_pkgname/build
}
package_gobject-introspection-git() {
depends+=("gobject-introspection-runtime-git=$pkgver-$pkgrel")
- DESTDIR="$pkgdir" meson install -C build
+ DESTDIR="$pkgdir" meson install -C $srcdir/$_pkgname/build
python -m compileall -d /usr/lib/$_pkgname "$pkgdir/usr/lib/$_pkgname"
python -O -m compileall -d /usr/lib/$_pkgname "$pkgdir/usr/lib/$_pkgname"