summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44f52dfa4511..5c0900143997 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = gocode-daemon
pkgdesc = An autocompletion daemon for the Go programming language (binary only)
- pkgver = 20150303
+ pkgver = 20170907
pkgrel = 1
url = https://github.com/nsf/gocode
arch = i686
arch = x86_64
license = MIT
depends = go
- source = https://github.com/nsf/gocode/archive/v.20150303.tar.gz
- md5sums = d379961598b8a3c4a67a9d26df291c40
+ source = https://github.com/nsf/gocode/archive/v.20170907.tar.gz
+ sha256sums = 100dbf8a971b10728b7566d430d368a62e60c77b880be96dc0b6364364cac2b4
pkgname = gocode-daemon
diff --git a/PKGBUILD b/PKGBUILD
index 1b9cdfc54120..1190179d4bc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: yesuu zhang <yesuu79@qq.com>
pkgname=gocode-daemon
-pkgver=20150303
+pkgver=20170907
pkgrel=1
pkgdesc="An autocompletion daemon for the Go programming language (binary only)"
arch=('i686' 'x86_64')
url="https://github.com/nsf/gocode"
license=('MIT')
depends=('go')
-source=('https://github.com/nsf/gocode/archive/v.20150303.tar.gz')
-md5sums=('d379961598b8a3c4a67a9d26df291c40')
+source=('https://github.com/nsf/gocode/archive/v.20170907.tar.gz')
+sha256sums=('100dbf8a971b10728b7566d430d368a62e60c77b880be96dc0b6364364cac2b4')
build() {
- cd "${srcdir}/gocode-v.20150303"
+ cd "${srcdir}/gocode-v.20170907"
go build -o gocode
}
package() {
- cd "${srcdir}/gocode-v.20150303"
+ cd "${srcdir}/gocode-v.20170907"
install -Dm755 gocode "${pkgdir}/usr/bin/gocode"
}