summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5fa69e755ccb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = godbledger-bin
+ pkgdesc = Accounting Software with GRPC endpoints and SQL Backends
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://www.godbledger.com
+ arch = x86_64
+ license = GPL3
+ depends = glibc
+ provides = godbledger
+ source = godbledger-bin-0.2.1.tar.gz::https://github.com/darcys22/godbledger/releases/download/v0.2.1/godbledger-linux-x64-v0.2.1.tar.gz
+ sha256sums = 2482b77aa254bb33e15ae2aeb4fd21cb029e19dd53081e9160184c90e37e4710
+
+pkgname = godbledger-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57d24cab0842
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=godbledger-bin
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="Accounting Software with GRPC endpoints and SQL Backends"
+arch=('x86_64')
+url="https://www.godbledger.com"
+license=('GPL3')
+depends=('glibc')
+provides=('godbledger')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/darcys22/godbledger/releases/download/v${pkgver}/godbledger-linux-x64-v${pkgver}.tar.gz")
+sha256sums=('2482b77aa254bb33e15ae2aeb4fd21cb029e19dd53081e9160184c90e37e4710')
+
+package() {
+ cd godbledger-linux-x64-v${pkgver}
+ install -Dm755 reporter -t "${pkgdir}/usr/bin"
+ install -Dm755 godbledger -t "${pkgdir}/usr/bin"
+ install -Dm755 ledger_cli -t "${pkgdir}/usr/bin"
+} \ No newline at end of file