summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile16
-rw-r--r--PKGBUILD4
3 files changed, 21 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c9a24218b30..465848e5fd84 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = godot
pkgdesc = An advanced, feature packed, multi-platform 2D and 3D game engine
- pkgver = 3.1.2
+ pkgver = 3.2.3
pkgrel = 1
url = http://www.godotengine.org
arch = i686
@@ -18,8 +18,8 @@ pkgbase = godot
depends = libglvnd
conflicts = godot-git
conflicts = godot-pulse
- source = https://github.com/godotengine/godot/archive/3.1.2-stable.tar.gz
- sha256sums = be2ed8d3f0dc6dd0a19e1fe562b2cc4de7d562d5f67ac6bf3dd67b4a1c69b218
+ source = https://github.com/godotengine/godot/archive/3.2.3-stable.tar.gz
+ sha256sums = 4c2a8e7da1ad05c6223b0ff6cf2be124dad6708b56a8ec9910dc2aaf82a553ae
pkgname = godot
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..f0ea750fb716
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,16 @@
+.PHONY: get-checksum
+get-checksum:
+ updpkgsums
+
+.PHONY: update
+update: get-checksum
+ makepkg --printsrcinfo > .SRCINFO
+
+# you may want to do a setup previous to use this target
+# follow https://wiki.archlinux.org/index.php/DeveloperWiki:Building_in_a_clean_chroot#Classic_way
+.PHONY: build
+build:
+ @echo "updating ${CHROOT}/root chroot environment..."
+ @arch-nspawn ${CHROOT}/root pacman -Syu
+ @echo "building package in isolation"
+ makechrootpkg -c -r ${CHROOT}
diff --git a/PKGBUILD b/PKGBUILD
index 62473a3d187b..fc42c26d7deb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Matthew Bentley <matthew@mtbentley.us>
pkgname=godot
-pkgver=3.1.2
+pkgver=3.2.3
pkgrel=1
pkgdesc="An advanced, feature packed, multi-platform 2D and 3D game engine"
url="http://www.godotengine.org"
@@ -22,7 +22,7 @@ fi
source=(
"https://github.com/godotengine/godot/archive/${pkgver}-stable.tar.gz"
)
-sha256sums=('be2ed8d3f0dc6dd0a19e1fe562b2cc4de7d562d5f67ac6bf3dd67b4a1c69b218')
+sha256sums=('4c2a8e7da1ad05c6223b0ff6cf2be124dad6708b56a8ec9910dc2aaf82a553ae')
build() {
cd "${srcdir}"/${pkgname}-${pkgver}-stable