summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD46
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..560552f118b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = godot-headless
+ pkgdesc = An advanced, feature packed, multi-platform 2D and 3D game engine
+ pkgver = 3.2.1
+ pkgrel = 1
+ url = http://www.godotengine.org
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = scons
+ makedepends = gcc
+ makedepends = yasm
+ depends = freetype2
+ depends = alsa-lib
+ depends = libglvnd
+ conflicts = godot
+ conflicts = godot-git
+ conflicts = godot-pulse
+ source = https://github.com/godotengine/godot/archive/3.2.1-stable.tar.gz
+ sha256sums = 0f9635e5c014713340160d8bd0cbfc6d34a36d39402a84eaa0d8c5dee4d1c6f0
+
+pkgname = godot-headless
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1af45d4deafe
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/*
+pkg/*
+*.gz
+*.log
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58adc6d5e82c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Borislav Kosharov <bosakmaw@gmail.com>
+# Contributor: Jorge Araya Navarro <jorgejavieran@yahoo.com.mx>
+# Contributor: Cristian Porras <porrascristian@gmail.com>
+# Contributor: Matthew Bentley <matthew@mtbentley.us>
+
+pkgname=godot-headless
+pkgver=3.2.1
+pkgrel=1
+pkgdesc='An advanced, feature packed, multi-platform 2D and 3D game engine'
+url='http://www.godotengine.org'
+license=('MIT')
+arch=('i686' 'x86_64')
+makedepends=('scons' 'gcc' 'yasm')
+depends=('freetype2' 'alsa-lib' 'libglvnd')
+conflicts=('godot' 'godot-git' 'godot-pulse')
+_arch=''
+if test "$CARCH" == x86_64; then
+ _arch=('64')
+else
+ _arch=('32')
+fi
+
+source=(
+ "https://github.com/godotengine/godot/archive/${pkgver}-stable.tar.gz"
+)
+sha256sums=('0f9635e5c014713340160d8bd0cbfc6d34a36d39402a84eaa0d8c5dee4d1c6f0')
+
+build() {
+ cd "${srcdir}"/godot-${pkgver}-stable
+
+ scons platform=server \
+ tools=yes \
+ target=release_debug \
+ use_llvm=no \
+ colored=yes \
+ pulseaudio=no bits=${_arch} -j $((`nproc`+1))
+}
+
+package() {
+ cd "${srcdir}"/godot-${pkgver}-stable
+
+ install -D -m755 bin/godot_server.x11.opt.tools.${_arch} "${pkgdir}"/usr/bin/godot
+ install -D -m644 "${srcdir}"/godot-${pkgver}-stable/LICENSE.txt "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+ install -D -m644 "${srcdir}"/godot-${pkgver}-stable/misc/dist/linux/godot.6 "${pkgdir}"/usr/share/man/man6/godot.6
+}
+