summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbac3a38ce09..06bb7263c73b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,21 @@
pkgbase = godot-mono-bin
pkgdesc = Godot is an advanced, feature packed, multi-platform 2D and 3D game engine. It provides a huge set of common tools, so you can just focus on making your game without reinventing the wheel.
- pkgver = 3.0.1
+ pkgver = 3.0.2
pkgrel = 1
url = https://www.godotengine.org
arch = x86_64
license = MIT
depends = mono>=5.4.0
- optdepends = msbuild-bin
+ depends = msbuild-stable
+ optdepends = dotnet-sdk
provides = godot-mono-bin
- conflicts = godot
- conflicts = godot-git
- replaces = godot
- replaces = godot-git
+ conflicts = godot-mono
source = godot-mono.desktop
source = icons.tar.gz
md5sums = c8ba9f7656b2c2db9a3ec385b3848bf5
md5sums = 281c83d55c6a4d39fb9710e6f143bc5a
- source_x86_64 = godot-mono-bin-3.0.1.zip::https://downloads.tuxfamily.org/godotengine/3.0.1/mono/Godot_v3.0.1-stable_mono_x11_64.zip
- md5sums_x86_64 = 24ad184f35aa393c2ba7cea557fde1e2
+ source_x86_64 = godot-mono-bin-3.0.2.zip::https://downloads.tuxfamily.org/godotengine/3.0.2/mono/Godot_v3.0.2-stable_mono_x11_64.zip
+ md5sums_x86_64 = 602c755b8d837477d40169b6ddc47592
pkgname = godot-mono-bin
diff --git a/PKGBUILD b/PKGBUILD
index 6c052830e8d0..90c4b182dbd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,20 @@
# Maintainer: Marvin Dalheimer <me@marvin-dalheimer.de>
pkgname=godot-mono-bin
-pkgver=3.0.1
+pkgver=3.0.2
pkgrel=1
pkgdesc="Godot is an advanced, feature packed, multi-platform 2D and 3D game engine. It provides a huge set of common tools, so you can just focus on making your game without reinventing the wheel."
arch=("x86_64")
url="https://www.godotengine.org"
license=('MIT')
provides=("godot-mono-bin")
-conflicts=("godot" "godot-git")
-replaces=("godot" "godot-git")
-depends=("mono>=5.4.0")
-optdepends=("msbuild-bin")
+conflicts=("godot-mono")
+depends=("mono>=5.4.0" "msbuild-stable")
+optdepends=("dotnet-sdk")
source=("godot-mono.desktop" "icons.tar.gz")
source_x86_64+=("$pkgname-$pkgver.zip::https://downloads.tuxfamily.org/godotengine/"$pkgver"/mono/Godot_v"$pkgver"-stable_mono_x11_64.zip")
md5sums=('c8ba9f7656b2c2db9a3ec385b3848bf5'
'281c83d55c6a4d39fb9710e6f143bc5a')
-md5sums_x86_64=('24ad184f35aa393c2ba7cea557fde1e2')
+md5sums_x86_64=('602c755b8d837477d40169b6ddc47592')
package() {
mkdir -p "$pkgdir/opt/$pkgname"
@@ -27,7 +26,6 @@ package() {
cp "$srcdir/godot-mono.desktop" "$pkgdir/usr/share/applications/godot-mono.desktop"
cp -a "$srcdir/icons/." "$pkgdir/usr/share/icons/hicolor"
- cp -a "$srcdir/icons/." "$pkgdir/usr/share/icons/gnome"
chmod +x "$pkgdir/opt/$pkgname/godot/Godot_v"$pkgver"-stable_mono_x11.64"