summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD37
2 files changed, 34 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06bb7263c73b..71b5aec8c1e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,24 @@
pkgbase = godot-mono-bin
pkgdesc = Godot is an advanced, feature packed, multi-platform 2D and 3D game engine. It provides a huge set of common tools, so you can just focus on making your game without reinventing the wheel.
- pkgver = 3.0.2
+ pkgver = 3.0.3
pkgrel = 1
url = https://www.godotengine.org
+ arch = i686
arch = x86_64
license = MIT
- depends = mono>=5.4.0
+ depends = mono>=5.12.0
+ depends = dotnet-sdk
depends = msbuild-stable
- optdepends = dotnet-sdk
provides = godot-mono-bin
conflicts = godot-mono
source = godot-mono.desktop
source = icons.tar.gz
md5sums = c8ba9f7656b2c2db9a3ec385b3848bf5
md5sums = 281c83d55c6a4d39fb9710e6f143bc5a
- source_x86_64 = godot-mono-bin-3.0.2.zip::https://downloads.tuxfamily.org/godotengine/3.0.2/mono/Godot_v3.0.2-stable_mono_x11_64.zip
- md5sums_x86_64 = 602c755b8d837477d40169b6ddc47592
+ source_i686 = godot-mono-bin-3.0.3-i686.zip::https://downloads.tuxfamily.org/godotengine/3.0.3/mono/Godot_v3.0.3-stable_mono_x11_32.zip
+ md5sums_i686 = 77a0bc1b0708a0843c94e95f9b387176
+ source_x86_64 = godot-mono-bin-3.0.3-x86_64.zip::https://downloads.tuxfamily.org/godotengine/3.0.3/mono/Godot_v3.0.3-stable_mono_x11_64.zip
+ md5sums_x86_64 = f81c27e6414bf9f3306ddb859aa4f7b3
pkgname = godot-mono-bin
diff --git a/PKGBUILD b/PKGBUILD
index 90c4b182dbd1..05de8c5e0c7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: Marvin Dalheimer <me@marvin-dalheimer.de>
pkgname=godot-mono-bin
-pkgver=3.0.2
+pkgver=3.0.3
pkgrel=1
pkgdesc="Godot is an advanced, feature packed, multi-platform 2D and 3D game engine. It provides a huge set of common tools, so you can just focus on making your game without reinventing the wheel."
-arch=("x86_64")
+arch=("i686" "x86_64")
url="https://www.godotengine.org"
license=('MIT')
provides=("godot-mono-bin")
conflicts=("godot-mono")
-depends=("mono>=5.4.0" "msbuild-stable")
-optdepends=("dotnet-sdk")
+depends=("mono>=5.12.0" "dotnet-sdk" "msbuild-stable")
source=("godot-mono.desktop" "icons.tar.gz")
-source_x86_64+=("$pkgname-$pkgver.zip::https://downloads.tuxfamily.org/godotengine/"$pkgver"/mono/Godot_v"$pkgver"-stable_mono_x11_64.zip")
+source_i686=("$pkgname-$pkgver-i686.zip::https://downloads.tuxfamily.org/godotengine/"$pkgver"/mono/Godot_v"$pkgver"-stable_mono_x11_32.zip")
+source_x86_64=("$pkgname-$pkgver-x86_64.zip::https://downloads.tuxfamily.org/godotengine/"$pkgver"/mono/Godot_v"$pkgver"-stable_mono_x11_64.zip")
md5sums=('c8ba9f7656b2c2db9a3ec385b3848bf5'
'281c83d55c6a4d39fb9710e6f143bc5a')
-md5sums_x86_64=('602c755b8d837477d40169b6ddc47592')
+md5sums_i686=('77a0bc1b0708a0843c94e95f9b387176')
+md5sums_x86_64=('f81c27e6414bf9f3306ddb859aa4f7b3')
package() {
mkdir -p "$pkgdir/opt/$pkgname"
@@ -22,12 +23,26 @@ package() {
mkdir -p "$pkgdir/usr/share/icons/hicolor"
mkdir -p "$pkgdir/usr/share/applications"
- cp -r "$srcdir/Godot_v"$pkgver"-stable_mono_x11_64" "$pkgdir/opt/$pkgname/godot"
-
+ case $CARCH in
+ "i686")
+ cp -r "$srcdir/Godot_v${pkgver}-stable_mono_x11_32" "$pkgdir/opt/$pkgname/godot"
+ ;;
+ "x86_64")
+ cp -r "$srcdir/Godot_v${pkgver}-stable_mono_x11_64" "$pkgdir/opt/$pkgname/godot"
+ ;;
+ esac
+
cp "$srcdir/godot-mono.desktop" "$pkgdir/usr/share/applications/godot-mono.desktop"
cp -a "$srcdir/icons/." "$pkgdir/usr/share/icons/hicolor"
- chmod +x "$pkgdir/opt/$pkgname/godot/Godot_v"$pkgver"-stable_mono_x11.64"
-
- ln -s "/opt/"$pkgname"/godot/Godot_v"$pkgver"-stable_mono_x11.64" "$pkgdir/usr/bin/godot-mono"
+ case $CARCH in
+ "i686")
+ chmod +x "$pkgdir/opt/$pkgname/godot/Godot_v${pkgver}-stable_mono_x11.32"
+ ln -s "$pkgdir/opt/$pkgname/godot/Godot_v${pkgver}-stable_mono_x11.32" "$pkgdir/usr/bin/godot-mono"
+ ;;
+ "x86_64")
+ chmod +x "$pkgdir/opt/$pkgname/godot/Godot_v${pkgver}-stable_mono_x11.64"
+ ln -s "$pkgdir/opt/$pkgname/godot/Godot_v${pkgver}-stable_mono_x11.64" "$pkgdir/usr/bin/godot-mono"
+ ;;
+ esac
}