summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--Makefile16
-rw-r--r--PKGBUILD42
3 files changed, 24 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 465848e5fd84..82346f5c149c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
-pkgbase = godot
+pkgbase = godot-voxel
pkgdesc = An advanced, feature packed, multi-platform 2D and 3D game engine
pkgver = 3.2.3
pkgrel = 1
url = http://www.godotengine.org
- arch = i686
arch = x86_64
license = MIT
makedepends = scons
@@ -16,10 +15,13 @@ pkgbase = godot
depends = libxrandr
depends = libxi
depends = libglvnd
+ conflicts = godot
conflicts = godot-git
conflicts = godot-pulse
source = https://github.com/godotengine/godot/archive/3.2.3-stable.tar.gz
+ source = https://github.com/Zylann/godot_voxel/archive/godot3.2.3.zip
sha256sums = 4c2a8e7da1ad05c6223b0ff6cf2be124dad6708b56a8ec9910dc2aaf82a553ae
+ sha256sums = c8b212909961fd398b417b7562d6c483975ccc9cb2649660c4f95f438907acf5
-pkgname = godot
+pkgname = godot-voxel
diff --git a/Makefile b/Makefile
deleted file mode 100644
index f0ea750fb716..000000000000
--- a/Makefile
+++ /dev/null
@@ -1,16 +0,0 @@
-.PHONY: get-checksum
-get-checksum:
- updpkgsums
-
-.PHONY: update
-update: get-checksum
- makepkg --printsrcinfo > .SRCINFO
-
-# you may want to do a setup previous to use this target
-# follow https://wiki.archlinux.org/index.php/DeveloperWiki:Building_in_a_clean_chroot#Classic_way
-.PHONY: build
-build:
- @echo "updating ${CHROOT}/root chroot environment..."
- @arch-nspawn ${CHROOT}/root pacman -Syu
- @echo "building package in isolation"
- makechrootpkg -c -r ${CHROOT}
diff --git a/PKGBUILD b/PKGBUILD
index fc42c26d7deb..d8a2e48603b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,46 @@
-# Maintainer: Jorge Araya Navarro <jorgejavieran@yahoo.com.mx>
+# Maintainer: dalz <aur @t alsd d0t eu>
+# Contributor: Jorge Araya Navarro <jorgejavieran@yahoo.com.mx>
# Contributor: Cristian Porras <porrascristian@gmail.com>
# Contributor: Matthew Bentley <matthew@mtbentley.us>
-pkgname=godot
+pkgname=godot-voxel
pkgver=3.2.3
pkgrel=1
pkgdesc="An advanced, feature packed, multi-platform 2D and 3D game engine"
url="http://www.godotengine.org"
license=('MIT')
-arch=('i686' 'x86_64')
+arch=('x86_64')
makedepends=('scons' 'gcc' 'yasm')
depends=('libxcursor' 'libxinerama' 'freetype2' 'alsa-lib' 'libxrandr' 'libxi' 'libglvnd')
-conflicts=("godot-git" "godot-pulse")
-_arch=''
-if test "$CARCH" == x86_64; then
- _arch=('64')
-else
- _arch=('32')
-fi
-
-source=(
- "https://github.com/godotengine/godot/archive/${pkgver}-stable.tar.gz"
-)
-sha256sums=('4c2a8e7da1ad05c6223b0ff6cf2be124dad6708b56a8ec9910dc2aaf82a553ae')
+conflicts=("godot" "godot-git" "godot-pulse")
+source=("https://github.com/godotengine/godot/archive/${pkgver}-stable.tar.gz"
+ "https://github.com/Zylann/godot_voxel/archive/godot${pkgver}.zip")
+sha256sums=('4c2a8e7da1ad05c6223b0ff6cf2be124dad6708b56a8ec9910dc2aaf82a553ae'
+ 'c8b212909961fd398b417b7562d6c483975ccc9cb2649660c4f95f438907acf5')
build() {
- cd "${srcdir}"/${pkgname}-${pkgver}-stable
+ ln -s "$srcdir/godot_voxel-godot$pkgver" "$srcdir/godot-$pkgver-stable/modules/voxel"
+
+ cd "${srcdir}/godot-${pkgver}-stable"
scons platform=x11 \
tools=yes \
target=release_debug \
use_llvm=no \
colored=yes \
- pulseaudio=no bits=${_arch} -j $((`nproc`+1))
+ pulseaudio=no bits=64 -j $((`nproc`+1))
}
package() {
cd "${srcdir}"
- install -Dm644 "${srcdir}"/${pkgname}-${pkgver}-stable/misc/dist/linux/org.godotengine.Godot.desktop "${pkgdir}"/usr/share/applications/godot.desktop
- install -Dm644 "${srcdir}"/${pkgname}-${pkgver}-stable/icon.svg "${pkgdir}"/usr/share/pixmaps/godot.svg
+ install -Dm644 "${srcdir}"/godot-${pkgver}-stable/misc/dist/linux/org.godotengine.Godot.desktop "${pkgdir}"/usr/share/applications/godot.desktop
+ install -Dm644 "${srcdir}"/godot-${pkgver}-stable/icon.svg "${pkgdir}"/usr/share/pixmaps/godot.svg
- cd "${srcdir}"/${pkgname}-${pkgver}-stable
+ cd "${srcdir}"/godot-${pkgver}-stable
- install -D -m755 bin/godot.x11.opt.tools.${_arch} "${pkgdir}"/usr/bin/godot
- install -D -m644 "${srcdir}"/${pkgname}-${pkgver}-stable/LICENSE.txt "${pkgdir}"/usr/share/licenses/godot/LICENSE
- install -D -m644 "${srcdir}"/${pkgname}-${pkgver}-stable/misc/dist/linux/godot.6 "${pkgdir}"/usr/share/man/man6/godot.6
+ install -D -m755 bin/godot.x11.opt.tools.64 "${pkgdir}"/usr/bin/godot
+ install -D -m644 "${srcdir}"/godot-${pkgver}-stable/LICENSE.txt "${pkgdir}"/usr/share/licenses/godot/LICENSE
+ install -D -m644 "${srcdir}"/godot-${pkgver}-stable/misc/dist/linux/godot.6 "${pkgdir}"/usr/share/man/man6/godot.6
}