summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD52
-rw-r--r--godot.desktop8
-rw-r--r--icon.pngbin0 -> 3188 bytes
4 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd66933783b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = godot
+ pkgdesc = An advanced, feature packed, multi-platform 2D and 3D game engine
+ pkgver = 1.1
+ pkgrel = 4
+ url = http://www.godotengine.org
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = scons
+ depends = glu
+ depends = libxcursor
+ depends = alsa-lib
+ depends = freetype2
+ depends = mesa
+ conflicts = godot-git
+ source = https://github.com/okamstudio/godot/archive/1.1-stable.tar.gz
+ source = godot.desktop
+ source = icon.png
+ md5sums = 87eb2fc3518ce7a27957fada1ba003e9
+ md5sums = dca7c5c5682bdc8cc83386034e0d7d07
+ md5sums = f756e85756a9cbc06a328414abf74585
+
+pkgname = godot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..748d8c06b6ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Jorge Araya Navarro <elcorreo@deshackra.com>
+# Contributor: Cristian Porras <porrascristian@gmail.com>
+# Contributor: Matthew Bentley <matthew@mtbentley.us>
+
+pkgname=godot
+pkgver=1.1
+pkgrel=4
+pkgdesc="An advanced, feature packed, multi-platform 2D and 3D game engine"
+url="http://www.godotengine.org"
+license=('MIT')
+arch=('i686' 'x86_64')
+makedepends=('scons')
+depends=('glu' 'libxcursor' 'alsa-lib' 'freetype2' 'mesa')
+optdepends=()
+conflicts=("godot-git")
+_arch=''
+if test "$CARCH" == x86_64; then
+ _arch=('64')
+else
+ _arch=('32')
+fi
+
+source=(
+ "https://github.com/okamstudio/godot/archive/${pkgver}-stable.tar.gz"
+ godot.desktop
+ icon.png
+)
+md5sums=('87eb2fc3518ce7a27957fada1ba003e9'
+ 'dca7c5c5682bdc8cc83386034e0d7d07'
+ 'f756e85756a9cbc06a328414abf74585')
+
+build() {
+ cd "${srcdir}"/${pkgname}-${pkgver}-stable
+
+ sed -n '/\/* Copyright/,/IN THE SOFTWARE./p' main/main.cpp | sed 's/\/\*//' | sed 's/\*\///' > LICENSE
+
+ scons platform=x11 target=release_debug
+}
+
+package() {
+
+ cd "${srcdir}"
+
+ install -Dm644 godot.desktop "${pkgdir}"/usr/share/applications/godot.desktop
+ install -Dm644 icon.png "${pkgdir}"/usr/share/pixmaps/godot.png
+
+ cd "${srcdir}"/${pkgname}-${pkgver}-stable
+
+ install -D -m755 bin/godot.x11.tools.${_arch} "${pkgdir}"/usr/bin/godot
+ install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/godot/LICENSE
+}
+
diff --git a/godot.desktop b/godot.desktop
new file mode 100644
index 000000000000..1e2e1545c597
--- /dev/null
+++ b/godot.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Godot
+Comment=Application for making games
+Exec=/usr/bin/godot %U
+Icon=godot
+Terminal=false
+Type=Application
+Categories=Utility;Game;
diff --git a/icon.png b/icon.png
new file mode 100644
index 000000000000..2a38417ca48c
--- /dev/null
+++ b/icon.png
Binary files differ