summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c5c69e0191b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = goenv
+ pkgdesc = Like pyenv and rbenv, but for Go.
+ pkgver = 2.0.0beta11
+ pkgrel = 1
+ url = https://github.com/syndbg/goenv
+ arch = i686
+ arch = x86_64
+ license = MIT
+ source = goenv-2.0.0beta11.tar.gz::https://github.com/syndbg/goenv/archive/2.0.0beta11.tar.gz
+ md5sums = 971e0e2cf572af5dabb6f7c8eb7b1be0
+
+pkgname = goenv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af46d72d6a60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+pkgname=goenv
+pkgver=2.0.0beta11
+pkgrel=1
+pkgdesc="Like pyenv and rbenv, but for Go."
+arch=('i686' 'x86_64')
+url="https://github.com/syndbg/goenv"
+license=('MIT')
+# https://github.com/syndbg/goenv/archive/2.0.0beta11.tar.gz
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+md5sums=('971e0e2cf572af5dabb6f7c8eb7b1be0')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ for file in $(ls -1 libexec/); do
+ install -D -m755 libexec/${file} "${pkgdir}/usr/lib/goenv/libexec/${file}"
+ done
+
+}