summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD21
-rw-r--r--gog-crypt-of-the-necrodancer.install15
3 files changed, 28 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef1823264d9f..01787a0875d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,28 @@
pkgbase = gog-crypt-of-the-necrodancer
pkgdesc = A roguelike rhythm game! Move on the beat to navigate ever changing dungeons
- pkgver = 2.1.0.3
+ pkgver = 1.29.14917
pkgrel = 1
+ epoch = 1
install = gog-crypt-of-the-necrodancer.install
arch = i686
arch = x86_64
license = custom
- source = local://gog_crypt_of_the_necrodancer_2.1.0.3.sh
+ source = local://crypt_of_the_necrodancer_en_1_29_14917.sh
source = gog-crypt-of-the-necrodancer
source = gog-crypt-of-the-necrodancer.desktop
+ source = gog-crypt-of-the-necrodancer.install
sha256sums = SKIP
sha256sums = d80562a04ded4b25bca9738267d1d93d2be8fef74570aa7d00d83471c4e71121
sha256sums = 9753ea711a428a24333cb37be1f11a3a35860072723e89dd7599d1842f0f4f89
- depends_i686 = glibc
- depends_i686 = alsa-lib
- depends_i686 = libgl
- depends_x86_64 = lib32-glibc
- depends_x86_64 = lib32-alsa-lib
- depends_x86_64 = lib32-libgl
+ sha256sums = 05a773f76b64ffe89b099f5c1e373061d1ffc1183ba0859ef7dfefdae9dc9434
pkgname = gog-crypt-of-the-necrodancer
+ depends_i686 = libglvnd
+ depends_i686 = openal
+ depends_i686 = libxrandr
+ depends_i686 = libpulse
+ depends_x86_64 = lib32-libglvnd
+ depends_x86_64 = lib32-openal
+ depends_x86_64 = lib32-libxrandr
+ depends_x86_64 = lib32-libpulse
diff --git a/PKGBUILD b/PKGBUILD
index e4cc66cc9d3e..6ac1393592c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
-# Maintainer: Luke Chen <doomer at yahoo dot com>
+# Maintainer: 5anya <sanya@national.shitposting.agency>
pkgname=gog-crypt-of-the-necrodancer
_pkgname=crypt-of-the-necrodancer
-pkgver=2.1.0.3
+epoch=1
+pkgver=1.29.14917
+_pkgver=1_29_14917
pkgrel=1
pkgdesc="A roguelike rhythm game! Move on the beat to navigate ever changing dungeons"
arch=('i686' 'x86_64')
license=('custom')
-depends_i686=('glibc' 'alsa-lib' 'libgl')
-depends_x86_64=('lib32-glibc' 'lib32-alsa-lib' 'lib32-libgl')
-optdepends_i686=()
-optdepends_x86_64=()
install=${pkgname}.install
-source=("local://gog_crypt_of_the_necrodancer_${pkgver}.sh"
+source=("local://crypt_of_the_necrodancer_en_${_pkgver}.sh"
"$pkgname"
- "$pkgname.desktop")
+ "$pkgname.desktop"
+ "$pkgname.install")
sha256sums=(SKIP
'd80562a04ded4b25bca9738267d1d93d2be8fef74570aa7d00d83471c4e71121'
- '9753ea711a428a24333cb37be1f11a3a35860072723e89dd7599d1842f0f4f89')
+ '9753ea711a428a24333cb37be1f11a3a35860072723e89dd7599d1842f0f4f89'
+ '05a773f76b64ffe89b099f5c1e373061d1ffc1183ba0859ef7dfefdae9dc9434')
+PKGEXT=".pkg.tar"
package() {
+ depends_i686=('libglvnd' 'openal' 'libxrandr' 'libpulse')
+ depends_x86_64=('lib32-libglvnd' 'lib32-openal' 'lib32-libxrandr' 'lib32-libpulse')
mkdir -p "$pkgdir"/opt/gog/$_pkgname
cp -r data/noarch/* "$pkgdir"/opt/gog/$_pkgname
install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
diff --git a/gog-crypt-of-the-necrodancer.install b/gog-crypt-of-the-necrodancer.install
index 7c653e44d3f3..744f0da5ccac 100644
--- a/gog-crypt-of-the-necrodancer.install
+++ b/gog-crypt-of-the-necrodancer.install
@@ -1,18 +1,9 @@
post_install() {
- update-desktop-database -q
touch /opt/gog/crypt-of-the-necrodancer/game/data/played.dat
touch /opt/gog/crypt-of-the-necrodancer/game/data/save_data.xml
touch /opt/gog/crypt-of-the-necrodancer/game/data/save_data.xml_TEMP
- chmod 777 /opt/gog/crypt-of-the-necrodancer/game/data/played.dat
- chmod 777 /opt/gog/crypt-of-the-necrodancer/game/data/save_data.xml
- chmod 777 /opt/gog/crypt-of-the-necrodancer/game/data/save_data.xml_TEMP
+ chmod 666 /opt/gog/crypt-of-the-necrodancer/game/data/played.dat
+ chmod 666 /opt/gog/crypt-of-the-necrodancer/game/data/save_data.xml
+ chmod 666 /opt/gog/crypt-of-the-necrodancer/game/data/save_data.xml_TEMP
echo "==> The save is located in /opt/gog/crypt-of-the-necrodancer/game/data/"
}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}