summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD75
2 files changed, 48 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e9dba9e28f6..53cab8158fe1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = gog-owlboy
pkgdesc = Owlboy is a 'hi-bit' adventure game, where you can fly and explore a brand new world in the clouds!
- pkgver = 2.0.0.1
+ pkgver = 2.2.0.3
pkgrel = 1
url = http://www.owlboygame.com/
arch = i686
arch = x86_64
license = custom
optdepends = firejail: Automatically sandbox this application from your OS
- source = gog://gog_owlboy_2.0.0.1.sh
- source = gog-owlboy.desktop
source = gog-owlboy
- sha256sums = 76958e0bb434d2514873aaddb892bc6c7055c39799ecde5f62a56345136853fc
- sha256sums = 8574e2463800004ddf97e49d2760d834413bf51fda4b1a57ead8cc10b07ac4f2
+ source = gog-owlboy.desktop
+ source = file://gog_owlboy_2.2.0.3.sh
sha256sums = 160b4d0fb275d3c1d4d6d574ca4085579e944e67dd32bd0a0c6e79f2e3d105a6
+ sha256sums = 8574e2463800004ddf97e49d2760d834413bf51fda4b1a57ead8cc10b07ac4f2
+ sha256sums = 41cc985f9399bb59a4da78a0ffbeae9d8ec7fda8dee3f409b93c9d978a8f8562
pkgname = gog-owlboy
diff --git a/PKGBUILD b/PKGBUILD
index 2701631842e2..ff58af195545 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,61 @@
# Maintainer: Dan Beste <dan.ray.beste@gmail.com>
+# Notes:
+# + gog:// DLAGENT:
+# - A gog:// DLAGENT can be configured in /etc/makepkg.conf to
+# automatically pull game files from GOG.
+# - https://github.com/Sude-/lgogdownloader
+
pkgname='gog-owlboy'
-pkgver=2.0.0.1
+pkgver=2.2.0.3
pkgrel=1
pkgdesc="Owlboy is a 'hi-bit' adventure game, where you can fly and explore a brand new world in the clouds!"
url="http://www.owlboygame.com/"
license=('custom')
arch=('i686' 'x86_64')
optdepends=(
- 'firejail: Automatically sandbox this application from your OS'
+ 'firejail: Automatically sandbox this application from your OS'
)
source=(
- "gog://${pkgname//-/_}_${pkgver}.sh"
- "${pkgname}.desktop"
- "${pkgname}"
+ "${pkgname}"
+ "${pkgname}.desktop"
+ "file://${pkgname//-/_}_${pkgver}.sh"
)
sha256sums=(
- '76958e0bb434d2514873aaddb892bc6c7055c39799ecde5f62a56345136853fc'
- '8574e2463800004ddf97e49d2760d834413bf51fda4b1a57ead8cc10b07ac4f2'
- '160b4d0fb275d3c1d4d6d574ca4085579e944e67dd32bd0a0c6e79f2e3d105a6'
-)
-DLAGENTS=(
- "gog::/usr/bin/echo %u Download the GOG file to $PWD or set up a gog:// DLAGENT."
+ '160b4d0fb275d3c1d4d6d574ca4085579e944e67dd32bd0a0c6e79f2e3d105a6'
+ '8574e2463800004ddf97e49d2760d834413bf51fda4b1a57ead8cc10b07ac4f2'
+ '41cc985f9399bb59a4da78a0ffbeae9d8ec7fda8dee3f409b93c9d978a8f8562'
)
-package(){
- # Install game
- install -d "${pkgdir}/opt/${pkgname}/"
- install -d "${pkgdir}/opt/${pkgname}/support"
- install -d "${pkgdir}/usr/bin/"
-
- cp -r "data/noarch/game/" "${pkgdir}/opt/${pkgname}/"
- find "${pkgdir}/opt/${pkgname}" -type d -exec chmod 755 {} \;
+package() {
+ install -d "${pkgdir}/opt/${pkgname}/"
+ install -d "${pkgdir}/opt/${pkgname}/support/"
+ install -d "${pkgdir}/usr/bin/"
+ install -d "${pkgdir}/usr/share/applications/"
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -d "${pkgdir}/usr/share/pixmaps/"
- install -Dm755 "data/noarch/start.sh" \
- "${pkgdir}/opt/${pkgname}/"
- install -Dm755 data/noarch/support/*.{sh,shlib} -t \
- "${pkgdir}/opt/${pkgname}/support"
+ cp -r data/noarch/game "${pkgdir}/opt/${pkgname}/"
+ find "${pkgdir}/opt/${pkgname}" -type d -exec chmod 755 {} \;
- # Desktop integration
- install -Dm 644 "data/noarch/support/icon.png" \
- "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
- install -Dm644 "data/noarch/docs/End User License Agreement.txt" \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm 644 "${srcdir}/${pkgname}.desktop" \
- "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -Dm755 "${srcdir}/${pkgname}" \
- "${pkgdir}/usr/bin/${pkgname}"
+ install -m 755 \
+ "${srcdir}/${pkgname}" \
+ "${pkgdir}/usr/bin/${pkgname}"
+ install -m 755 \
+ data/noarch/start.sh \
+ "${pkgdir}/opt/${pkgname}/"
+ install -m 755 \
+ data/noarch/support/*.{sh,shlib} \
+ "${pkgdir}/opt/${pkgname}/support/"
+ install -m 644 \
+ 'data/noarch/docs/End User License Agreement.txt' \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -m 644 \
+ "data/noarch/support/icon.png" \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -m 644 \
+ "${srcdir}/${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
}
+
+# vim: ts=2 sw=2 et: