summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD56
-rw-r--r--gog-owlboy13
-rw-r--r--gog-owlboy.desktop10
5 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9dc65e6b8209
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gog-owlboy
+ pkgdesc = Owlboy is a 'hi-bit' adventure game, where you can fly and explore a brand new world in the clouds!
+ pkgver = 2.0.0.1
+ pkgrel = 1
+ url = http://www.owlboygame.com/
+ arch = i686
+ arch = x86_64
+ license = custom
+ optdepends = firejail: Automatically sandbox this application from your OS
+ source = gog://gog_owlboy_2.0.0.1.sh
+ source = gog-owlboy.desktop
+ source = gog-owlboy
+ sha256sums = 76958e0bb434d2514873aaddb892bc6c7055c39799ecde5f62a56345136853fc
+ sha256sums = 8574e2463800004ddf97e49d2760d834413bf51fda4b1a57ead8cc10b07ac4f2
+ sha256sums = 22b307b01c96852220e1be33e1cfa19410c7dd009135540e6d48ed35bace17f0
+
+pkgname = gog-owlboy
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c762d3698d3e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+# Blacklist:
+*
+
+# Whitelist:
+!PKGBUILD
+!.SRCINFO
+!gog-owlboy
+!gog-owlboy.desktop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d137d8d115a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Krakn - Dan.Ray.Beste@gmail.com
+# Thanks to: Ainola for the base PKGBUILD (gog-undertale)
+
+pkgname=gog-owlboy
+pkgver=2.0.0.1
+pkgrel=1
+pkgdesc="Owlboy is a 'hi-bit' adventure game, where you can fly and explore a brand new world in the clouds!"
+url="http://www.owlboygame.com/"
+license=('custom')
+arch=('i686' 'x86_64')
+# Dependencies are included with the gog_owlboy_$version.sh file.
+depends_x86_64=()
+depends_i686=()
+# If Firejail is installed, this application will be sandboxed automatically.
+optdepends=('firejail: Automatically sandbox this application from your OS')
+source=(
+ "gog://${pkgname//-/_}_${pkgver}.sh"
+ "${pkgname}.desktop"
+ "$pkgname")
+sha256sums=(
+ "76958e0bb434d2514873aaddb892bc6c7055c39799ecde5f62a56345136853fc"
+ "8574e2463800004ddf97e49d2760d834413bf51fda4b1a57ead8cc10b07ac4f2"
+ "22b307b01c96852220e1be33e1cfa19410c7dd009135540e6d48ed35bace17f0"
+)
+
+# You need to download the gog.com installer file manually or with lgogdownloader.
+DLAGENTS+=("gog::/usr/bin/echo %u Download the GOG file to \"$PWD\" or set up a gog:// DLAGENT.")
+
+# Prevent compressing final package
+PKGEXT=".pkg.tar"
+
+package(){
+ cd "${srcdir}"
+
+ # Install game
+ install -d "${pkgdir}/opt/${pkgname}/"
+ install -d "${pkgdir}/opt/${pkgname}/support"
+ install -d "${pkgdir}/usr/bin/"
+ cp -r "data/noarch/game/" "${pkgdir}/opt/${pkgname}/"
+
+
+ find "${pkgdir}/opt/${pkgname}" -type d -exec chmod 755 {} \;
+ install -Dm755 "data/noarch/start.sh" \
+ "${pkgdir}/opt/${pkgname}/"
+ install -Dm755 data/noarch/support/*.{sh,shlib} -t \
+ "${pkgdir}/opt/${pkgname}/support"
+
+ # Desktop integration
+ install -Dm 644 "data/noarch/support/icon.png" \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "data/noarch/docs/End User License Agreement.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 "${srcdir}/${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm755 "$srcdir/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}
diff --git a/gog-owlboy b/gog-owlboy
new file mode 100644
index 000000000000..0e19fcd06d89
--- /dev/null
+++ b/gog-owlboy
@@ -0,0 +1,13 @@
+#! /bin/sh
+
+run="/opt/gog-owlboy/start.sh"
+# The launcher fails unless in its dir.
+cd /opt/gog-undertale/ || exit 1
+
+if which firejail >/dev/null 2>&1 && [ -z "$FIREJAIL_IGNORE" ]; then
+ echo "Firejail detected. Enforcing a sandbox"
+ echo "To bypass Firejail enforcement, run FIREJAIL_IGNORE=1 $run."
+ firejail --caps.drop=all "$run"
+else
+ "$run"
+fi
diff --git a/gog-owlboy.desktop b/gog-owlboy.desktop
new file mode 100644
index 000000000000..514e4d5e5cf3
--- /dev/null
+++ b/gog-owlboy.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=OWLBOY
+Comment=Owlboy is a 'hi-bit' adventure game, where you can fly and explore a brand new world in the clouds!
+Exec=gog-owlboy
+Icon=gog-owlboy
+Type=Application
+Terminal=false
+StartupNotify=true
+Categories=Game;AudioVideo;
+Encoding=UTF-8