summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
-rw-r--r--gog-planescape-torment25
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7af90fcc6c79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gog-planescape-torment
+ pkgdesc = Sigil... A place with gates that lead anywhere in existence, provided you have the proper key.
+ pkgver = 1.0.0.6
+ pkgrel = 3
+ url = http://www.gog.com/game/planescape_torment
+ arch = i686
+ arch = x86_64
+ groups = games
+ license = custom
+ depends = freetype2
+ depends = wine
+ source = local://gog_planescape_torment_1.0.0.6.tar.gz
+ source = gog-planescape-torment
+ sha256sums = e574accb26e6ae20876386b926df8c982bb7ccda8ffc70154915b291fb571845
+ sha256sums = 21d8d21cab91ab140380273d430ecf98cf95abb3a1fe7f6ca03657e97d6da9c1
+
+pkgname = gog-planescape-torment
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c709ed48f526
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer : André Fettouhi <a.fettouhi@gmail.com>
+# Contributor : Noctivivans <noctivivans@gmail.com>
+
+pkgname=gog-planescape-torment
+pkgver=1.0.0.6
+pkgrel=3
+pkgdesc="Sigil... A place with gates that lead anywhere in existence, provided you have the proper key."
+arch=("i686" "x86_64")
+url="http://www.gog.com/game/planescape_torment"
+license=("custom")
+groups=("games")
+source=("local://gog_planescape_torment_${pkgver}.tar.gz" "gog-planescape-torment")
+sha256sums=('e574accb26e6ae20876386b926df8c982bb7ccda8ffc70154915b291fb571845'
+ '21d8d21cab91ab140380273d430ecf98cf95abb3a1fe7f6ca03657e97d6da9c1')
+depends=(freetype2 wine)
+#options=('!strip')
+PKGEXT=.pkg.tar
+
+package() {
+mkdir -p "${pkgdir}"/opt/gog/planescape-torment
+mv "${srcdir}"/Planescape\ Torment/prefix/drive_c/GOG\ Games/Planescape\ Torment/* "${pkgdir}"/opt/gog/planescape-torment
+sed -i s/'HD0:=.\+'/'HD0:=C:\\planescape-torment\\'/ "${pkgdir}"/opt/gog/planescape-torment/Torment.ini
+sed -i s/'CD1:=.\+'/'CD1:=C:\\planescape-torment\\data\\'/ "${pkgdir}"/opt/gog/planescape-torment/Torment.ini
+sed -i s/'CD2:=.\+'/'CD2:=C:\\planescape-torment\\data\\'/ "${pkgdir}"/opt/gog/planescape-torment/Torment.ini
+sed -i s/'CD3:=.\+'/'CD3:=C:\\planescape-torment\\data\\'/ "${pkgdir}"/opt/gog/planescape-torment/Torment.ini
+sed -i s/'CD4:=.\+'/'CD4:=C:\\planescape-torment\\data\\'/ "${pkgdir}"/opt/gog/planescape-torment/Torment.ini
+sed -i s/'CD5:=.\+'/'CD5:=C:\\planescape-torment\\data\\'/ "${pkgdir}"/opt/gog/planescape-torment/Torment.ini
+install -Dm644 "${srcdir}"/Planescape\ Torment/support/gog-planescape-torment-primary.desktop "${pkgdir}"/usr/share/applications/gog-planescape-torment.desktop
+install -Dm644 "${srcdir}"/Planescape\ Torment/support/gog-planescape-torment.png "${pkgdir}"/usr/share/pixmaps/gog-planescape-torment.png
+install -Dm644 "${srcdir}"/Planescape\ Torment/docs/End\ User\ License\ Agreement.txt "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
+install -Dm755 "${srcdir}/gog-planescape-torment" "${pkgdir}/usr/bin/gog-planescape-torment"
+}
diff --git a/gog-planescape-torment b/gog-planescape-torment
new file mode 100644
index 000000000000..983eede398f1
--- /dev/null
+++ b/gog-planescape-torment
@@ -0,0 +1,25 @@
+#!/usr/bin/bash
+ID=planescape-torment
+WRITABLE='*.ini *.bif *.key'
+EXE=Torment.exe
+USERDIR=$HOME/.gog/$ID
+export WINEPREFIX=$USERDIR/.wine
+export WINEDEBUG=-all
+
+if ! [ -d $USERDIR ]
+then
+ INSTALLDIR=/opt/gog/$ID
+ mkdir -p $(dirname $USERDIR)
+ cp -as $INSTALLDIR $USERDIR
+ WINEARCH=win32 wineboot -i
+ rm $WINEPREFIX/dosdevices/"z:"
+ ln -s $USERDIR $WINEPREFIX/drive_c
+ cd $USERDIR
+ for file in $WRITABLE
+ do
+ cp -a --remove-destination $INSTALLDIR/$file $file
+ done
+fi
+
+cd $WINEPREFIX/drive_c/$ID
+wine $EXE