summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD37
-rwxr-xr-xStardewValley7
4 files changed, 23 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7aad704cb65..22ec2c626fd0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = gog-stardew-valley
pkgdesc = You’ve inherited your grandfather’s old farm plot in Stardew Valley. Armed with hand-me-down tools and a few coins, you set out to begin your new life.
- pkgver = 1.3.33
+ pkgver = 1.6.3
pkgrel = 1
epoch = 1
url = http://stardewvalley.net/
arch = x86_64
license = custom
+ options = !strip
+ options = staticlibs
source = gog-stardew-valley
source = gog-stardew-valley.desktop
- source = local:///stardew_valley_1_3_33_26507.sh
- source = StardewValley
+ source = local:///stardew_valley_1_6_3_24087_6495347694_72214.sh
sha256sums = 9f51b56b351824493c381731f29175b0897fa0dc4169a9b9160b5a12003883dc
sha256sums = ca0fe151f73f5e8b594b226e1b0539655a2d95a7848eb0e43961cb6daa0de2ff
- sha256sums = 3230f1b94f120b1453c82e011b4650f65b1d8172e6467927edfe67e1b9b278aa
- sha256sums = 0c6826084d72917748e54f9308b7395f8d3780b4a745860839203e2af428d202
+ sha256sums = a37f3b96802232e1bb9383969edcd8babca2eb0b310f0d8cfc3e219baddc0d31
pkgname = gog-stardew-valley
-
diff --git a/.gitignore b/.gitignore
index 1fd4ed99b292..f49fad3ce96b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -7,4 +7,3 @@
!.SRCINFO
!gog-stardew-valley
!gog-stardew-valley.desktop
-!StardewValley
diff --git a/PKGBUILD b/PKGBUILD
index 90a7f47bc3cf..c705d1031832 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,9 @@
-# Maintainer: Dan Beste <drb@wishalloy.io>
+# Contributor: Rafael Silva <perigoso@riseup.net>
+# Contributor: Dan Beste <drb@wishalloy.io>
+# Contributor: Alastair Hughes
pkgname='gog-stardew-valley'
-pkgver=1.3.36
+pkgver=1.6.3
pkgrel=1
# Fix upstream versioning shenanigans:
epoch=1
@@ -11,21 +13,20 @@ life."
url='http://stardewvalley.net/'
license=('custom')
arch=('x86_64')
+options=('!strip' 'staticlibs')
source=(
"${pkgname}"
"${pkgname}.desktop"
- 'local:///stardew_valley_1_3_36_27827.sh'
- 'StardewValley'
-)
-sha256sums=(
- '9f51b56b351824493c381731f29175b0897fa0dc4169a9b9160b5a12003883dc'
- 'ca0fe151f73f5e8b594b226e1b0539655a2d95a7848eb0e43961cb6daa0de2ff'
- 'af39d5f9d2c0c8be338af16f73bcd0dd1268f2af1cfe47f83f1f39b9cd0099e2'
- '0c6826084d72917748e54f9308b7395f8d3780b4a745860839203e2af428d202'
+ 'local:///stardew_valley_1_6_3_24087_6495347694_72214.sh'
)
+sha256sums=('9f51b56b351824493c381731f29175b0897fa0dc4169a9b9160b5a12003883dc'
+ 'ca0fe151f73f5e8b594b226e1b0539655a2d95a7848eb0e43961cb6daa0de2ff'
+ 'a37f3b96802232e1bb9383969edcd8babca2eb0b310f0d8cfc3e219baddc0d31')
+
+
package() {
install -d "${pkgdir}/opt/${pkgname}/"
- install -d "${pkgdir}/opt/${pkgname}/support/"
+ install -d "${pkgdir}/opt/${pkgname}/support/yad/64"
install -d "${pkgdir}/usr/bin/"
install -d "${pkgdir}/usr/share/applications/"
install -d "${pkgdir}/usr/share/licenses/${pkgname}/"
@@ -43,6 +44,12 @@ package() {
install -m 755 \
data/noarch/support/*.{sh,shlib} \
"${pkgdir}/opt/${pkgname}/support/"
+ install -m 755 \
+ 'data/noarch/support/yad/yad.sh' \
+ "${pkgdir}/opt/${pkgname}/support/yad/"
+ install -m 755 \
+ 'data/noarch/support/yad/64/yad' \
+ "${pkgdir}/opt/${pkgname}/support/yad/64/"
install -m 644 \
'data/noarch/docs/End User License Agreement.txt' \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
@@ -52,14 +59,6 @@ package() {
install -m 644 \
"${srcdir}/${pkgname}.desktop" \
"${pkgdir}/usr/share/applications/${pkgname}.desktop"
-
- # Workarounds for upstream silliness:
- cd "${pkgdir}/opt/gog-stardew-valley/game"
- # Unless i686 is requested, I am only going to support machine architectures
- # that I can test with:
- ln -s mcs.bin.x86_64 mcs
- # Simplified "bootstrapping" script:
- install -m 755 "${srcdir}/StardewValley" StardewValley
}
# vim: ts=2 sw=2 et:
diff --git a/StardewValley b/StardewValley
deleted file mode 100755
index 1f0f8fbb3bec..000000000000
--- a/StardewValley
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/usr/bin/env bash
-
-cd "$(dirname "$0")"
-
-if [[ -f mcs ]]; then
- ./StardewValley.bin.x86_64 "${@}"
-fi