summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD59
-rw-r--r--gog-stardew-valley.desktop4
-rw-r--r--gog-stardew-valley.profile17
5 files changed, 63 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 658ab5e2426e..09583ea3d04f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = gog-stardew-valley
- pkgdesc = You’ve inherited your grandfather’s old farm plot in Stardew Valley. Armed with hand-me-down tools and a few coins, you set out to begin your new life.
+ pkgdesc = You’ve inherited your grandfather’s old farm plot in Stardew Valley. Armed with hand-me-down tools and a few coins, you set out to begin your new life." url="http://stardewvalley.net/
pkgver = 2.3.0.4
pkgrel = 1
- url = http://stardewvalley.net/
arch = i686
arch = x86_64
license = custom
depends = openal
depends = sdl2
optdepends = firejail: Automatically sandbox this application from your OS
- source = gog://gog_stardew_valley_2.3.0.4.sh
- source = gog-stardew-valley.desktop
source = gog-stardew-valley
- sha256sums = 88e1fae7226c7bfa91cb28c137c24867e12b1a0b6e824e6ffe73e1eefc166aac
- sha256sums = 1dc48ca70b7274c065ee65e285102b07962096b650a34a898d10d6749039d3ca
+ source = gog-stardew-valley.desktop
+ source = gog-stardew-valley.profile
+ source = gog://gog_stardew_valley_2.3.0.4.sh
sha256sums = 7e03458fab2b426cce514a42663e56efd33d072bd319f513a5c8bdf7f4e09905
+ sha256sums = ca0fe151f73f5e8b594b226e1b0539655a2d95a7848eb0e43961cb6daa0de2ff
+ sha256sums = 380fac814e9076e4a886e85a2f48f1245434099340d622459cd51413b908a0cd
+ sha256sums = 88e1fae7226c7bfa91cb28c137c24867e12b1a0b6e824e6ffe73e1eefc166aac
depends_i686 = lib32-openal
depends_i686 = lib32-sdl2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a229dd6a443f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+# Blacklist:
+*
+
+# Whitelist:
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!gog-stardew-valley
+!gog-stardew-valley.desktop
+!gog-stardew-valley.profile
diff --git a/PKGBUILD b/PKGBUILD
index 6383cdbbb661..f93c97fd9dc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Krakn - Dan.Ray.Beste@gmail.com
+# Maintainer: Dan Beste <dan.ray.beste@gmail.com>
# Thanks to: Ainola for the base PKGBUILD (gog-undertale)
# All dependencies are included with the gog_owlboy_$version.sh file.
@@ -6,66 +6,61 @@
# libCSteamworks - ??? Not entirely sure what this provides...
# libsteam_api - ??? Not entirely sure what this provides...
-pkgname=gog-stardew-valley
+pkgname='gog-stardew-valley'
pkgver=2.3.0.4
pkgrel=1
-pkgdesc="You’ve inherited your grandfather’s old farm plot in Stardew Valley. Armed with hand-me-down tools and a few coins, you set out to begin your new life."
-url="http://stardewvalley.net/"
-license=(
- 'custom'
-)
-arch=(
- 'i686'
- 'x86_64'
-)
-depends_x86_64=(
- 'openal'
- 'sdl2'
-)
-depends_i686=(
- 'lib32-openal'
- 'lib32-sdl2'
-)
+pkgdesc='You’ve inherited your grandfather’s old farm plot in Stardew Valley. Armed with hand-me-down tools and a few coins, you set out to begin your new life."
+url="http://stardewvalley.net/'
+license=('custom')
+arch=('i686' 'x86_64')
+depends_x86_64=('openal' 'sdl2')
+depends_i686=('lib32-openal' 'lib32-sdl2')
optdepends=(
'firejail: Automatically sandbox this application from your OS'
)
source=(
- "gog://${pkgname//-/_}_${pkgver}.sh"
- "${pkgname}.desktop"
"${pkgname}"
+ "${pkgname}.desktop"
+ "${pkgname}.profile"
+ "gog://${pkgname//-/_}_${pkgver}.sh"
)
sha256sums=(
- '88e1fae7226c7bfa91cb28c137c24867e12b1a0b6e824e6ffe73e1eefc166aac'
- '1dc48ca70b7274c065ee65e285102b07962096b650a34a898d10d6749039d3ca'
'7e03458fab2b426cce514a42663e56efd33d072bd319f513a5c8bdf7f4e09905'
+ 'ca0fe151f73f5e8b594b226e1b0539655a2d95a7848eb0e43961cb6daa0de2ff'
+ '380fac814e9076e4a886e85a2f48f1245434099340d622459cd51413b908a0cd'
+ '88e1fae7226c7bfa91cb28c137c24867e12b1a0b6e824e6ffe73e1eefc166aac'
)
DLAGENTS+=(
"gog::/usr/bin/echo %u Download the GOG file to ${PWD} or set up a gog:// DLAGENT."
)
package() {
- cd "${srcdir}"
-
# Install game
install -d "${pkgdir}/opt/${pkgname}/"
install -d "${pkgdir}/opt/${pkgname}/support"
install -d "${pkgdir}/usr/bin/"
cp -r "data/noarch/game/" "${pkgdir}/opt/${pkgname}/"
-
+ # Desktop integration
find "${pkgdir}/opt/${pkgname}" -type d -exec chmod 755 {} \;
- install -Dm755 "data/noarch/start.sh" \
+ install -Dm 755 \
+ data/noarch/start.sh \
"${pkgdir}/opt/${pkgname}/"
- install -Dm755 data/noarch/support/*.{sh,shlib} -t \
+ install -Dm 755 \
+ data/noarch/support/*.{sh,shlib} -t \
"${pkgdir}/opt/${pkgname}/support"
# Desktop integration
- install -Dm 644 "data/noarch/support/icon.png" \
+ install -Dm 644 \
+ data/noarch/support/icon.png \
"${pkgdir}/usr/share/pixmaps/${pkgname}.png"
- install -Dm644 "data/noarch/docs/End User License Agreement.txt" \
+ install -Dm 644 \
+ 'data/noarch/docs/End User License Agreement.txt' \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm 644 "${srcdir}/${pkgname}.desktop" \
+ install -Dm 644 \
+ "${srcdir}/${pkgname}.desktop" \
"${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -Dm755 "${srcdir}/${pkgname}" \
+ install -Dm 755 \
+ "${srcdir}/${pkgname}" \
"${pkgdir}/usr/bin/${pkgname}"
}
diff --git a/gog-stardew-valley.desktop b/gog-stardew-valley.desktop
index 0e1b17ac8946..78d1bb8cb81f 100644
--- a/gog-stardew-valley.desktop
+++ b/gog-stardew-valley.desktop
@@ -1,6 +1,6 @@
[Desktop Entry]
-Name=Stardew Valley
-Comment=You’ve inherited your grandfather’s old farm plot in Stardew Valley. Armed with hand-me-down tools and a few coins, you set out to begin your new life.
+Name=STARDEW VALLEY
+Comment=You’ve inherited your grandfather’s old farm plot in Stardew Valley. Armed with hand-me-down tools and a few coins, you set out to begin your new life. Can you learn to live off the land and turn these overgrown fields into a thriving home?
Exec=gog-stardew-valley
Icon=gog-stardew-valley
Type=Application
diff --git a/gog-stardew-valley.profile b/gog-stardew-valley.profile
new file mode 100644
index 000000000000..550e93e4711c
--- /dev/null
+++ b/gog-stardew-valley.profile
@@ -0,0 +1,17 @@
+# Modified steam.profile
+
+# TODO:
+# Fix controller support.
+
+noblacklist ${HOME}/.config/StardewValley
+include /etc/firejail/disable-common.inc
+include /etc/firejail/disable-programs.inc
+include /etc/firejail/disable-devel.inc
+include /etc/firejail/disable-passwdmgr.inc
+
+caps.drop all
+netfilter
+nonewprivs
+noroot
+protocol unix,inet,inet6,netlink
+seccomp