summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--gogios.install8
3 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80c26c259c69..c4c44959de93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = gogios
pkgdesc = Checks to see if required services are still running on important machines.
- pkgver = 2.2.1.r0.g82eb451
+ pkgver = 3.0.0.r1.g041f5a1
pkgrel = 1
url = https://github.com/bkasin/gogios
install = gogios.install
arch = x86_64
license = MIT
- makedepends = go
- makedepends = make
+ optdepends = nmap
optdepends = nginx
+ optdepends = sqlite
optdepends = gogios-plugins
provides = gogios
conflicts = gogios-bin
diff --git a/PKGBUILD b/PKGBUILD
index 000c6b6fd3aa..788bc070ea4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,19 @@
# Maintainer: Bailey Kasin <bailey@gingertechnology.net> (https://angrysysadmins.tech)
pkgname=gogios
-pkgver=2.2.1.r0.g82eb451
+pkgver=3.0.0.r1.g041f5a1
pkgrel=1
pkgdesc="Checks to see if required services are still running on important machines."
arch=('x86_64')
url="https://github.com/bkasin/gogios"
license=('MIT')
-makedepends=('go' 'make')
-optdepends=('nginx' 'gogios-plugins')
+#makedepends=('go' 'make')
+optdepends=(
+ 'nmap'
+ 'nginx'
+ 'sqlite'
+ 'gogios-plugins')
install=${pkgname}.install
diff --git a/gogios.install b/gogios.install
index aa07d8af0bd0..bbc739dd2bfa 100644
--- a/gogios.install
+++ b/gogios.install
@@ -9,6 +9,7 @@ pre_install() {
}
post_install() {
+ DATABASE_DIR=/var/lib/gogios
LOG_DIR=/var/log/gogios
SCRIPT_DIR=/usr/lib/gogios/scripts
@@ -16,6 +17,10 @@ post_install() {
chown -R -L gogios:gogios $LOG_DIR
chmod 755 $LOG_DIR
+ test -d $DATABASE_DIR || mkdir -p $DATABASE_DIR
+ chown -R -L gogios:gogios $DATABASE_DIR
+ chmod 755 $DATABASE_DIR
+
cp -f $SCRIPT_DIR/gogios.service /usr/lib/systemd/system/gogios.service
systemctl enable gogios || true
systemctl daemon-reload || true
@@ -30,9 +35,6 @@ post_install() {
echo "Making default check file"
cp /etc/gogios/example.json /etc/gogios/checks.json
fi
-
- # Gogios will fail to start if these files aren't owned
- chown gogios:gogios -R /opt/gogios
}
post_upgrade() {