summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD2
-rw-r--r--gogios.install2
3 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0ccdebbe423..99d67b30e713 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,6 +9,7 @@ pkgbase = gogios
makedepends = go
makedepends = make
optdepends = nginx
+ optdepends = nmap
provides = gogios
conflicts = gogios-bin
source = gogios::git+https://github.com/bkasin/gogios.git#branch=master
diff --git a/PKGBUILD b/PKGBUILD
index e42b18989ae6..191a150f25cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ url="https://github.com/bkasin/gogios"
license=('MIT')
makedepends=('go' 'make')
-optdepends=('nginx')
+optdepends=('nginx' 'nmap')
install=${pkgname}.install
diff --git a/gogios.install b/gogios.install
index e08b9c0e50a2..3dc82d2b6ca8 100644
--- a/gogios.install
+++ b/gogios.install
@@ -22,7 +22,7 @@ post_install() {
echo "gogios user already exists"
else
mkdir -p /var/spool/gogios
- useradd --system --no-create-home --shell /sbin/nologin gogios
+ useradd --system --user-group --home-dir /var/spool/gogios --shell /sbin/nologin gogios
chown gogios:gogios /var/spool/gogios
fi