summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--app.ini.patch12
-rw-r--r--app_new.ini58
-rw-r--r--app_old.ini58
5 files changed, 45 insertions, 95 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39dfc1669d6e..e0f1e9f4da37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gogs-git
pkgdesc = Gogs(Go Git Service) is a Self Hosted Git Service in the Go Programming Language. This is the current git version from branch master.
- pkgver = 20150823
+ pkgver = 20150920
pkgrel = 1
epoch = 1
url = http://gogs.io/
@@ -31,7 +31,7 @@ pkgbase = gogs-git
source = helper.sh
source = gogs::git+https://github.com/gogits/gogs.git#branch=master
sha512sums = 2b4303f850e3b13b2fc3c9f0bc5820dae431d228002b35f01be0d4bfbcf05de8dcec2a559a85e318b609e4a4d492d44306eadf5f6508fd72333b198661bb0bb7
- sha512sums = 939be9ad851ae6e20b786e2e189b0b67c0198edfc8c83442934ec48c7be073e03c75172e79f23a6ee1e0eb467c6fa18096a66d69d1142ebba28fdc8bb2a3964c
+ sha512sums = f80b4115ce39e6158beb7e6a68b7f0825e5c1320ba7c16f999986f2dfad0be08c238d220f556673f531080ddf540bd8e8eb6ea2559128109b0405baac163f013
sha512sums = e746dbdafc4c8d0b15a224dba95ae3151611ba9ff468ee6f0b1789e489955e4d7eaac0dbdf28a22e5b8211559af5950726f4a37d699a2490fd349f034401028c
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 87552d86b370..8c55fc5b231e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=gogs-git
_pkgname=gogs
_branch=master
-pkgver=20150823
+pkgver=20150920
pkgrel=1
epoch=1
pkgdesc="Gogs(Go Git Service) is a Self Hosted Git Service in the Go Programming Language. This is the current git version from branch ${_branch}."
@@ -32,7 +32,7 @@ source=('gogs.service'
"$_pkgname::git+https://${_gourl}.git#branch=${_branch}")
sha512sums=(2b4303f850e3b13b2fc3c9f0bc5820dae431d228002b35f01be0d4bfbcf05de8dcec2a559a85e318b609e4a4d492d44306eadf5f6508fd72333b198661bb0bb7
- 939be9ad851ae6e20b786e2e189b0b67c0198edfc8c83442934ec48c7be073e03c75172e79f23a6ee1e0eb467c6fa18096a66d69d1142ebba28fdc8bb2a3964c
+ f80b4115ce39e6158beb7e6a68b7f0825e5c1320ba7c16f999986f2dfad0be08c238d220f556673f531080ddf540bd8e8eb6ea2559128109b0405baac163f013
e746dbdafc4c8d0b15a224dba95ae3151611ba9ff468ee6f0b1789e489955e4d7eaac0dbdf28a22e5b8211559af5950726f4a37d699a2490fd349f034401028c
'SKIP')
@@ -76,9 +76,7 @@ prepare() {
get_gopm "$GOPATH/src/${_gourl}/.gopmfile" "$GOPATH/src"
msg2 "Download missing dependencies"
- go_get github.com/shurcooL/sanitized_anchor_name "$GOPATH/src/github.com/shurcooL/sanitized_anchor_name"
-# go_get golang.org/x/net "$GOPATH/src/golang.org/x/net"
-# go_get golang.org/x/text "$GOPATH/src/golang.org/x/text"
+# go_get github.com/shurcooL/sanitized_anchor_name "$GOPATH/src/github.com/shurcooL/sanitized_anchor_name"
msg2 "Workaround dependencies"
cd "$GOPATH/src/github.com/gogits/go-gogs-client/"
diff --git a/app.ini.patch b/app.ini.patch
index dd912fd9e8e1..f6cc8d1ee618 100644
--- a/app.ini.patch
+++ b/app.ini.patch
@@ -6,27 +6,27 @@
< ROOT =
---
> ROOT = /srv/gogs/repo
-43c43
+53c53
< STATIC_ROOT_PATH =
---
> STATIC_ROOT_PATH = /usr/share/themes/gogs/default
-59c59
+69c69
< PATH = data/gogs.db
---
> PATH = /srv/gogs/sqlite/gogs.db
-184c184
+160c160
< PROVIDER_CONFIG = data/sessions
---
> PROVIDER_CONFIG = /srv/gogs/sessions
-199c199
+175c175
< AVATAR_UPLOAD_PATH = data/avatars
---
> AVATAR_UPLOAD_PATH = /srv/gogs/data/avatars
-209c209
+185c185
< PATH = data/attachments
---
> PATH = /srv/gogs/data/attachments
-224c224
+200c200
< ROOT_PATH =
---
> ROOT_PATH = /var/log/gogs
diff --git a/app_new.ini b/app_new.ini
index 1a61538add51..9c75fc65b0d4 100644
--- a/app_new.ini
+++ b/app_new.ini
@@ -13,9 +13,19 @@ ROOT = /srv/gogs/repo
SCRIPT_TYPE = bash
[ui]
+; Number of repositories that are showed in one explore page
+EXPLORE_PAGING_NUM = 20
; Number of issues that are showed in one page
ISSUE_PAGING_NUM = 10
+[ui.admin]
+; Numer of users that are showed in one page
+USER_PAGING_NUM = 50
+
+[markdown]
+; Enable hard line break extension
+ENABLE_HARD_LINE_BREAK = false
+
[server]
PROTOCOL = http
DOMAIN = localhost
@@ -55,7 +65,7 @@ USER = root
PASSWD =
; For "postgres" only, either "disable", "require" or "verify-full"
SSL_MODE = disable
-; For "sqlite3" only
+; For "sqlite3" and "tidb"
PATH = /srv/gogs/sqlite/gogs.db
[admin]
@@ -89,6 +99,8 @@ ENABLE_REVERSE_PROXY_AUTHENTICATION = false
ENABLE_REVERSE_PROXY_AUTO_REGISTRATION = false
; Do not check minimum key size with corresponding type
DISABLE_MINIMUM_KEY_SIZE_CHECK = false
+; Enable captcha validation for registration
+ENABLE_CAPTCHA = true
[webhook]
; Hook task queue length
@@ -97,11 +109,13 @@ QUEUE_LENGTH = 1000
DELIVER_TIMEOUT = 5
; Allow insecure certification
SKIP_TLS_VERIFY = false
+; Number of history information in each page
+PAGING_NUM = 10
[mailer]
ENABLED = false
; Buffer length of channel, keep it as it is if you don't know what it is.
-SEND_BUFFER_LEN = 10
+SEND_BUFFER_LEN = 100
; Name displayed in mail title
SUBJECT = %(APP_NAME)s
; Mail server
@@ -125,44 +139,6 @@ FROM =
USER =
PASSWD =
-[oauth]
-ENABLED = false
-
-[oauth.github]
-ENABLED = false
-CLIENT_ID =
-CLIENT_SECRET =
-SCOPES = https://api.github.com/user
-AUTH_URL = https://github.com/login/oauth/authorize
-TOKEN_URL = https://github.com/login/oauth/access_token
-
-; Get client id and secret from
-; https://console.developers.google.com/project
-[oauth.google]
-ENABLED = false
-CLIENT_ID =
-CLIENT_SECRET =
-SCOPES = https://www.googleapis.com/auth/userinfo.email https://www.googleapis.com/auth/userinfo.profile
-AUTH_URL = https://accounts.google.com/o/oauth2/auth
-TOKEN_URL = https://accounts.google.com/o/oauth2/token
-
-[oauth.qq]
-ENABLED = false
-CLIENT_ID =
-CLIENT_SECRET =
-SCOPES = get_user_info
-; QQ 互联
-AUTH_URL = https://graph.qq.com/oauth2.0/authorize
-TOKEN_URL = https://graph.qq.com/oauth2.0/token
-
-[oauth.weibo]
-ENABLED = false
-CLIENT_ID =
-CLIENT_SECRET =
-SCOPES = all
-AUTH_URL = https://api.weibo.com/oauth2/authorize
-TOKEN_URL = https://api.weibo.com/oauth2/access_token
-
[cache]
; Either "memory", "redis", or "memcache", default is "memory"
ADAPTER = memory
@@ -210,7 +186,7 @@ PATH = /srv/gogs/data/attachments
; One or more allowed types, e.g. image/jpeg|image/png
ALLOWED_TYPES = image/jpeg|image/png
; Max size of each file. Defaults to 32MB
-MAX_SIZE = 32
+MAX_SIZE = 4
; Max number of files per upload. Defaults to 10
MAX_FILES = 5
diff --git a/app_old.ini b/app_old.ini
index 9b8e4145dc0b..9d956fa816d8 100644
--- a/app_old.ini
+++ b/app_old.ini
@@ -13,9 +13,19 @@ ROOT =
SCRIPT_TYPE = bash
[ui]
+; Number of repositories that are showed in one explore page
+EXPLORE_PAGING_NUM = 20
; Number of issues that are showed in one page
ISSUE_PAGING_NUM = 10
+[ui.admin]
+; Numer of users that are showed in one page
+USER_PAGING_NUM = 50
+
+[markdown]
+; Enable hard line break extension
+ENABLE_HARD_LINE_BREAK = false
+
[server]
PROTOCOL = http
DOMAIN = localhost
@@ -55,7 +65,7 @@ USER = root
PASSWD =
; For "postgres" only, either "disable", "require" or "verify-full"
SSL_MODE = disable
-; For "sqlite3" only
+; For "sqlite3" and "tidb"
PATH = data/gogs.db
[admin]
@@ -89,6 +99,8 @@ ENABLE_REVERSE_PROXY_AUTHENTICATION = false
ENABLE_REVERSE_PROXY_AUTO_REGISTRATION = false
; Do not check minimum key size with corresponding type
DISABLE_MINIMUM_KEY_SIZE_CHECK = false
+; Enable captcha validation for registration
+ENABLE_CAPTCHA = true
[webhook]
; Hook task queue length
@@ -97,11 +109,13 @@ QUEUE_LENGTH = 1000
DELIVER_TIMEOUT = 5
; Allow insecure certification
SKIP_TLS_VERIFY = false
+; Number of history information in each page
+PAGING_NUM = 10
[mailer]
ENABLED = false
; Buffer length of channel, keep it as it is if you don't know what it is.
-SEND_BUFFER_LEN = 10
+SEND_BUFFER_LEN = 100
; Name displayed in mail title
SUBJECT = %(APP_NAME)s
; Mail server
@@ -125,44 +139,6 @@ FROM =
USER =
PASSWD =
-[oauth]
-ENABLED = false
-
-[oauth.github]
-ENABLED = false
-CLIENT_ID =
-CLIENT_SECRET =
-SCOPES = https://api.github.com/user
-AUTH_URL = https://github.com/login/oauth/authorize
-TOKEN_URL = https://github.com/login/oauth/access_token
-
-; Get client id and secret from
-; https://console.developers.google.com/project
-[oauth.google]
-ENABLED = false
-CLIENT_ID =
-CLIENT_SECRET =
-SCOPES = https://www.googleapis.com/auth/userinfo.email https://www.googleapis.com/auth/userinfo.profile
-AUTH_URL = https://accounts.google.com/o/oauth2/auth
-TOKEN_URL = https://accounts.google.com/o/oauth2/token
-
-[oauth.qq]
-ENABLED = false
-CLIENT_ID =
-CLIENT_SECRET =
-SCOPES = get_user_info
-; QQ 互联
-AUTH_URL = https://graph.qq.com/oauth2.0/authorize
-TOKEN_URL = https://graph.qq.com/oauth2.0/token
-
-[oauth.weibo]
-ENABLED = false
-CLIENT_ID =
-CLIENT_SECRET =
-SCOPES = all
-AUTH_URL = https://api.weibo.com/oauth2/authorize
-TOKEN_URL = https://api.weibo.com/oauth2/access_token
-
[cache]
; Either "memory", "redis", or "memcache", default is "memory"
ADAPTER = memory
@@ -210,7 +186,7 @@ PATH = data/attachments
; One or more allowed types, e.g. image/jpeg|image/png
ALLOWED_TYPES = image/jpeg|image/png
; Max size of each file. Defaults to 32MB
-MAX_SIZE = 32
+MAX_SIZE = 4
; Max number of files per upload. Defaults to 10
MAX_FILES = 5