summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..013e07af4a8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Dec 12 13:36:55 UTC 2016
+pkgbase = gojot
+ pkgdesc = A command-line journal that is distributed and encrypted.
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://gojot.schollz.com/
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = go
+ options = !strip
+ options = !emptydirs
+ source = https://github.com/schollz/gojot/archive/latest.tar.gz
+ sha256sums = f72f4b919459e663e9759f2deb6ff5f6c7847dd2cf82bef4d47e67534c2c12bb
+
+pkgname = gojot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67f9d6868db3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
+
+pkgname=gojot
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="A command-line journal that is distributed and encrypted."
+arch=('x86_64' 'i686')
+url="https://gojot.schollz.com/"
+license=('MIT')
+makedepends=('go')
+options=('!strip' '!emptydirs')
+source=('https://github.com/schollz/gojot/archive/latest.tar.gz')
+sha256sums=('f72f4b919459e663e9759f2deb6ff5f6c7847dd2cf82bef4d47e67534c2c12bb')
+
+build() {
+ cd "$pkgname-latest"
+
+ go build
+}
+
+package() {
+ cd "$pkgname-latest"
+
+ install -Dm755 "$pkgname-latest" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}