summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f23c2d1d37dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gomuks-midek-git
+ pkgdesc = A terminal based Matrix client written in Go. Upload and pantalaimon support
+ pkgver = r560.235d8f2
+ pkgrel = 1
+ url = https://github.com/Midek/gomuks
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = go-pie
+ makedepends = git
+ depends = libolm
+ provides = gomuks
+ conflicts = gomuks
+ source = git://github.com/Midek/gomuks.git
+ sha512sums = SKIP
+
+pkgname = gomuks-midek-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35f4599e2436
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
+pkgname=gomuks-midek-git
+_name=gomuks
+pkgdesc='A terminal based Matrix client written in Go. Upload and pantalaimon support'
+pkgver=r560.235d8f2
+pkgrel=1
+url='https://github.com/Midek/gomuks'
+license=(GPL3)
+arch=(x86_64 i686)
+depends=(libolm)
+makedepends=(go-pie git)
+provides=(${_name})
+conflicts=("${provides[@]}")
+source=("git://github.com/Midek/${_name}.git")
+sha512sums=(SKIP)
+
+pkgver () {
+ cd "${srcdir}/${_name}"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git describe --always)"
+}
+prepare() {
+ cd "${srcdir}/${_name}"
+ # all the good stuff is in the revert_attachments branch
+ git checkout revert_attachments
+}
+
+build () {
+ cd "${srcdir}/${_name}"
+ # disable encryption so pantalaimon works
+ export CGO_ENABLED=0
+ go build -v \
+ -gcflags "all=-trimpath=${curdir}" \
+ -asmflags "all=-trimpath=${curdir}" \
+ -ldflags "-extldflags '${LDFLAGS}'" \
+ .
+}
+
+package () {
+ cd "${srcdir}/${_name}"
+ install -Dm755 gomuks "${pkgdir}/usr/bin/gomuks"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${_name}/README.md"
+}