summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.drone.yml18
-rw-r--r--README.md2
2 files changed, 20 insertions, 0 deletions
diff --git a/.drone.yml b/.drone.yml
new file mode 100644
index 000000000000..153d6fdd46e6
--- /dev/null
+++ b/.drone.yml
@@ -0,0 +1,18 @@
+kind: pipeline
+type: docker
+name: default
+
+steps:
+- name: fixperms
+ image: imrehg/archlinux-makepkg
+ user: root
+ commands:
+ - chown -R builder:builder .
+- name: build
+ image: imrehg/archlinux-makepkg
+ commands:
+ - yay -Suy --noconfirm
+ - namcap PKGBUILD
+ - makepkg -sci --noconfirm
+ - namcap *.pkg.tar.xz
+
diff --git a/README.md b/README.md
index 8327f138e08d..f27f5e331882 100644
--- a/README.md
+++ b/README.md
@@ -1,6 +1,8 @@
# AUR Gonic PKGBUILD
+[![Build Status](https://cloud.drone.io/api/badges/dpertin/aur-gonic/status.svg)](https://cloud.drone.io/dpertin/aur-gonic)
+
This repo contains the required files to generate an Archlinux package of
[gonic](https://github.com/sentriz/gonic),
a lightweight music streaming server written in Go, which implements the