summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
-rw-r--r--google_set_hostname.patch10
3 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6dfb36e6fdad..1ad58117e1e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = google-compute-engine
pkgdesc = Linux Guest Environment for Google Compute Engine
- pkgver = 20210113.00
+ pkgver = 20220211.00
pkgrel = 2
url = https://github.com/GoogleCloudPlatform/guest-configs
install = google-compute-engine.install
arch = any
license = Apache
+ depends = nvme-cli
depends = google-compute-engine-oslogin
depends = google-guest-agent
- source = google-compute-engine-20210113.00.tar.gz::https://github.com/GoogleCloudPlatform/guest-configs/archive/20210113.00.tar.gz
+ source = google-compute-engine-20220211.00.tar.gz::https://github.com/GoogleCloudPlatform/guest-configs/archive/20220211.00.tar.gz
source = google-compute-engine.install
source = google_set_hostname.patch
- sha256sums = 4d30fcfa368507f219ecf7e884442e5b556fbaec3f3367dc5c8b116f63be2977
+ sha256sums = eeb95c321a6e73a48e4cb988270b5ce210fb0654951deb153a48ad04dbc74947
sha256sums = 9b31cc5146d83374cc8f8da9f0ce924bbafeb932d0cf0ce60e4aec71d1f981b7
- sha256sums = 5cef3677dd373e81370ef6730643ba9dd20fb3bf47260e825ad37417da4fc6c3
+ sha256sums = f54b3bb58e1c4eb0b9d0c7d8f38244dbd1f6b9b9db8fe9880d4562c35eced704
pkgname = google-compute-engine
-
diff --git a/PKGBUILD b/PKGBUILD
index b81f572725f0..e9067848a3bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,19 +16,19 @@
# Maintainer: Samuel Littley <samuellittley@google.com>
pkgname='google-compute-engine'
-pkgver=20210113.00
+pkgver=20220211.00
pkgrel=2
pkgdesc='Linux Guest Environment for Google Compute Engine'
arch=('any')
url='https://github.com/GoogleCloudPlatform/guest-configs'
license=('Apache')
-depends=('google-compute-engine-oslogin' 'google-guest-agent')
+depends=('nvme-cli' 'google-compute-engine-oslogin' 'google-guest-agent')
source=("$pkgname-$pkgver.tar.gz::https://github.com/GoogleCloudPlatform/guest-configs/archive/$pkgver.tar.gz"
'google-compute-engine.install'
'google_set_hostname.patch')
-sha256sums=('4d30fcfa368507f219ecf7e884442e5b556fbaec3f3367dc5c8b116f63be2977'
+sha256sums=('eeb95c321a6e73a48e4cb988270b5ce210fb0654951deb153a48ad04dbc74947'
'9b31cc5146d83374cc8f8da9f0ce924bbafeb932d0cf0ce60e4aec71d1f981b7'
- '5cef3677dd373e81370ef6730643ba9dd20fb3bf47260e825ad37417da4fc6c3')
+ 'f54b3bb58e1c4eb0b9d0c7d8f38244dbd1f6b9b9db8fe9880d4562c35eced704')
install='google-compute-engine.install'
prepare() {
@@ -40,6 +40,7 @@ package() {
cd "$srcdir/guest-configs-$pkgver"
install -m644 -Dt "$pkgdir/etc/modprobe.d" src/etc/modprobe.d/*
install -m644 -Dt "$pkgdir/etc/sysctl.d" src/etc/sysctl.d/*
+ install -m644 -Dt "$pkgdir/usr/lib/udev" src/lib/udev/google_nvme_id
install -m644 -Dt "$pkgdir/usr/lib/udev/rules.d" src/lib/udev/rules.d/*
install -m755 -Dt "$pkgdir/usr/bin" src/usr/bin/*
ln -s /usr/bin/google_set_hostname "$pkgdir/etc/dhclient-exit-hooks"
diff --git a/google_set_hostname.patch b/google_set_hostname.patch
index 8aee98076069..a3200e53e221 100644
--- a/google_set_hostname.patch
+++ b/google_set_hostname.patch
@@ -1,10 +1,10 @@
-diff --unified --recursive --text guest-configs-20210113.00.orig/src/usr/bin/google_set_hostname guest-configs-20210113.00/src/usr/bin/google_set_hostname
---- guest-configs-20210113.00.orig/src/usr/bin/google_set_hostname 2021-01-24 16:23:33.145413281 +0000
-+++ guest-configs-20210113.00/src/usr/bin/google_set_hostname 2021-01-24 16:20:26.670408935 +0000
-@@ -37,7 +37,7 @@
+diff --unified --recursive --text guest-configs-20220211.00.orig/src/usr/bin/google_set_hostname guest-configs-20220211.00/src/usr/bin/google_set_hostname
+--- guest-configs-20220211.00.orig/src/usr/bin/google_set_hostname 2021-01-24 16:23:33.145413281 +0000
++++ guest-configs-20220211.00/src/usr/bin/google_set_hostname 2021-01-24 16:20:26.670408935 +0000
+@@ -43,7 +43,7 @@
# unqualified domain name.
- if [ -n "$new_host_name" ]; then
+ if [ -n "$new_host_name" ] && ! echo "$new_host_name" | grep -iq "metadata.google.internal"; then
- hostname "${new_host_name%%.*}"
+ hostnamectl set-hostname "${new_host_name%%.*}"