summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
-rw-r--r--google-compute-engine.install23
3 files changed, 46 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6408553e0399..762d6f19d552 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = google-compute-engine
- pkgdesc = Google Compute Engine guest environment
- pkgver = 20191210
+ pkgdesc = Linux Guest Environment for Google Compute Engine
+ pkgver = 20200731.00
pkgrel = 1
- url = https://github.com/GoogleCloudPlatform/compute-image-packages
+ url = https://github.com/GoogleCloudPlatform/guest-configs
+ install = google-compute-engine.install
arch = any
license = Apache
- depends = ethtool
depends = google-compute-engine-oslogin
- depends = inetutils
- depends = python-boto
- depends = python-distro
- depends = python-setuptools
- source = google-compute-engine-20191210.tar.gz::https://github.com/GoogleCloudPlatform/compute-image-packages/archive/v20191210.tar.gz
- sha256sums = 19a2ca537f876e4a19341646f2865c6429b8ea041a3a6651ff8c1ed966f72fe1
+ depends = google-guest-agent
+ source = google-compute-engine-20200731.00.tar.gz::https://github.com/GoogleCloudPlatform/guest-configs/archive/20200731.00.tar.gz
+ source = google-compute-engine.install
+ sha256sums = a5a8297ea30ba13c238a9a31e30daafd0d939507ab3310270b4becf6daa8128d
+ sha256sums = 9b31cc5146d83374cc8f8da9f0ce924bbafeb932d0cf0ce60e4aec71d1f981b7
pkgname = google-compute-engine
diff --git a/PKGBUILD b/PKGBUILD
index bd0e5bfac3da..97a8cca16565 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,33 +16,24 @@
# Maintainer: Samuel Littley <samuellittley@google.com>
pkgname='google-compute-engine'
-pkgver=20191210
+pkgver=20200731.00
pkgrel=1
-pkgdesc='Google Compute Engine guest environment'
+pkgdesc='Linux Guest Environment for Google Compute Engine'
arch=('any')
-url='https://github.com/GoogleCloudPlatform/compute-image-packages'
+url='https://github.com/GoogleCloudPlatform/guest-configs'
license=('Apache')
-depends=('ethtool' 'google-compute-engine-oslogin' 'inetutils' 'python-boto' 'python-distro' 'python-setuptools')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/GoogleCloudPlatform/compute-image-packages/archive/v$pkgver.tar.gz")
-sha256sums=('19a2ca537f876e4a19341646f2865c6429b8ea041a3a6651ff8c1ed966f72fe1')
-
-build() {
- cd "compute-image-packages-$pkgver/packages/python-google-compute-engine"
- python setup.py build
-}
+depends=('google-compute-engine-oslogin' 'google-guest-agent')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/GoogleCloudPlatform/guest-configs/archive/$pkgver.tar.gz"
+ 'google-compute-engine.install')
+sha256sums=('a5a8297ea30ba13c238a9a31e30daafd0d939507ab3310270b4becf6daa8128d'
+ '9b31cc5146d83374cc8f8da9f0ce924bbafeb932d0cf0ce60e4aec71d1f981b7')
+install='google-compute-engine.install'
package() {
- cd "compute-image-packages-$pkgver/packages"
- pushd python-google-compute-engine
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- popd
-
- pushd google-compute-engine/src
- install -m644 -Dt "$pkgdir/etc/modprobe.d" etc/modprobe.d/*
- install -m644 -Dt "$pkgdir/etc/sysctl.d" etc/sysctl.d/*
- install -m644 -Dt "$pkgdir/usr/lib/systemd/system/" lib/systemd/system/*
- install -m644 -Dt "$pkgdir/usr/lib/udev/rules.d" lib/udev/rules.d/*
- install -m755 -Dt "$pkgdir/usr/bin" usr/bin/*
+ cd "guest-configs-$pkgver"
+ install -m644 -Dt "$pkgdir/etc/modprobe.d" src/etc/modprobe.d/*
+ install -m644 -Dt "$pkgdir/etc/sysctl.d" src/etc/sysctl.d/*
+ install -m644 -Dt "$pkgdir/usr/lib/udev/rules.d" src/lib/udev/rules.d/*
+ install -m755 -Dt "$pkgdir/usr/bin" src/usr/bin/*
ln -s /usr/bin/google_set_hostname "$pkgdir/etc/dhclient-exit-hooks"
- popd
}
diff --git a/google-compute-engine.install b/google-compute-engine.install
new file mode 100644
index 000000000000..59997e9dbe6b
--- /dev/null
+++ b/google-compute-engine.install
@@ -0,0 +1,23 @@
+# Copyright 2020 Google LLC
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# https://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+pre_upgrade() {
+ if (( $(vercmp "$2" '20200731.00') < 0)); then
+ systemctl disable --now \
+ google-accounts-daemon \
+ google-clock-skew-daemon \
+ google-instance-setup \
+ google-network-daemon
+ fi
+}