summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
-rw-r--r--google_set_hostname.patch12
3 files changed, 26 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 641adf3d3716..6dfb36e6fdad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = google-compute-engine
pkgdesc = Linux Guest Environment for Google Compute Engine
pkgver = 20210113.00
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/GoogleCloudPlatform/guest-configs
install = google-compute-engine.install
arch = any
@@ -10,8 +10,10 @@ pkgbase = google-compute-engine
depends = google-guest-agent
source = google-compute-engine-20210113.00.tar.gz::https://github.com/GoogleCloudPlatform/guest-configs/archive/20210113.00.tar.gz
source = google-compute-engine.install
+ source = google_set_hostname.patch
sha256sums = 4d30fcfa368507f219ecf7e884442e5b556fbaec3f3367dc5c8b116f63be2977
sha256sums = 9b31cc5146d83374cc8f8da9f0ce924bbafeb932d0cf0ce60e4aec71d1f981b7
+ sha256sums = 5cef3677dd373e81370ef6730643ba9dd20fb3bf47260e825ad37417da4fc6c3
pkgname = google-compute-engine
diff --git a/PKGBUILD b/PKGBUILD
index e8b1ece6a6cd..b81f572725f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,20 +17,27 @@
pkgname='google-compute-engine'
pkgver=20210113.00
-pkgrel=1
+pkgrel=2
pkgdesc='Linux Guest Environment for Google Compute Engine'
arch=('any')
url='https://github.com/GoogleCloudPlatform/guest-configs'
license=('Apache')
depends=('google-compute-engine-oslogin' 'google-guest-agent')
source=("$pkgname-$pkgver.tar.gz::https://github.com/GoogleCloudPlatform/guest-configs/archive/$pkgver.tar.gz"
- 'google-compute-engine.install')
+ 'google-compute-engine.install'
+ 'google_set_hostname.patch')
sha256sums=('4d30fcfa368507f219ecf7e884442e5b556fbaec3f3367dc5c8b116f63be2977'
- '9b31cc5146d83374cc8f8da9f0ce924bbafeb932d0cf0ce60e4aec71d1f981b7')
+ '9b31cc5146d83374cc8f8da9f0ce924bbafeb932d0cf0ce60e4aec71d1f981b7'
+ '5cef3677dd373e81370ef6730643ba9dd20fb3bf47260e825ad37417da4fc6c3')
install='google-compute-engine.install'
+prepare() {
+ cd "$srcdir/guest-configs-$pkgver"
+ patch --strip=1 --input="$srcdir/google_set_hostname.patch"
+}
+
package() {
- cd "guest-configs-$pkgver"
+ cd "$srcdir/guest-configs-$pkgver"
install -m644 -Dt "$pkgdir/etc/modprobe.d" src/etc/modprobe.d/*
install -m644 -Dt "$pkgdir/etc/sysctl.d" src/etc/sysctl.d/*
install -m644 -Dt "$pkgdir/usr/lib/udev/rules.d" src/lib/udev/rules.d/*
diff --git a/google_set_hostname.patch b/google_set_hostname.patch
new file mode 100644
index 000000000000..8aee98076069
--- /dev/null
+++ b/google_set_hostname.patch
@@ -0,0 +1,12 @@
+diff --unified --recursive --text guest-configs-20210113.00.orig/src/usr/bin/google_set_hostname guest-configs-20210113.00/src/usr/bin/google_set_hostname
+--- guest-configs-20210113.00.orig/src/usr/bin/google_set_hostname 2021-01-24 16:23:33.145413281 +0000
++++ guest-configs-20210113.00/src/usr/bin/google_set_hostname 2021-01-24 16:20:26.670408935 +0000
+@@ -37,7 +37,7 @@
+ # unqualified domain name.
+
+ if [ -n "$new_host_name" ]; then
+- hostname "${new_host_name%%.*}"
++ hostnamectl set-hostname "${new_host_name%%.*}"
+
+ # If NetworkManager is installed set the hostname with nmcli.
+ # to resolve issues with NetworkManager resetting the hostname