summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD6
3 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b0dde6231bf..7e2be5413012 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,11 +4,11 @@ pkgbase = google-font-download
pkgrel = 1
url = https://github.com/neverpanic/google-font-download
arch = any
- license = BSD
+ license = BSD-2-Clause
checkdepends = xxd
depends = curl
depends = ncurses
- source = google-font-download-1.4.3-1.tar.gz::https://github.com/neverpanic/google-font-download/archive/1.4.3.tar.gz
+ source = google-font-download-1.4.3.tar.gz::https://github.com/neverpanic/google-font-download/archive/1.4.3.tar.gz
sha512sums = 977a9746d2c5ec7dbcb81cb401c5497bb169dac8d2fdd088b82c8de435e5e1a80fe76fea44e98c4ce093aa6a9401ec4f687372f706d246d08705ebc7325e634a
pkgname = google-font-download
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index 7f22296afe98..12fdd98cfeca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,10 +5,10 @@ pkgrel='1'
pkgdesc='Google Fonts web font downloader'
arch=('any')
url="https://github.com/neverpanic/$pkgname"
-license=('BSD')
+license=('BSD-2-Clause')
depends=('curl' 'ncurses')
checkdepends=('xxd')
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha512sums=('977a9746d2c5ec7dbcb81cb401c5497bb169dac8d2fdd088b82c8de435e5e1a80fe76fea44e98c4ce093aa6a9401ec4f687372f706d246d08705ebc7325e634a')
_sourcedirectory="$pkgname-$pkgver"
@@ -22,5 +22,5 @@ check() {
package() {
cd "$srcdir/$_sourcedirectory/"
install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
- install -Dm644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/BSD-2-Clause"
}