summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD23
3 files changed, 28 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e21e1238613a..a2b303421f76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = googledot-cursor-theme
pkgdesc = Cursor theme inspired on Google
- pkgver = 1.0.0
+ pkgver = 1.0.1
pkgrel = 1
url = https://www.pling.com/p/1215613
arch = any
license = GPL3
- makedepends = yarn
- makedepends = npm
makedepends = python-clickgen
depends = libxcursor
depends = libpng
- source = googledot-cursor-theme-1.0.0.tar.gz::https://github.com/ful1e5/Google_Cursor/archive/v1.0.0.tar.gz
- sha256sums = c83c3037a8e8e0b473467b3ed8db5ee0328dcaded38290d660e035cd01a0288a
+ noextract = googledot-cursor-theme-bitmaps-1.0.1.zip
+ source = googledot-cursor-theme-1.0.1.tar.gz::https://github.com/ful1e5/Google_Cursor/archive/v1.0.1.tar.gz
+ source = googledot-cursor-theme-bitmaps-1.0.1.zip::https://github.com/ful1e5/Google_Cursor/releases/download/v1.0.1/bitmaps.zip
+ sha256sums = 5eaaa21cb96e9c310d78dbb577e4c1109f6aa5e96c0dc054abb6c7b097a4a2cf
+ sha256sums = 61c0bff15a77cacf5367c5172bfe5014af258cfa9fbfa5df5c65f8d3aea095c5
pkgname = googledot-cursor-theme
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 1a95331f7c5a..b47cb6691f9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,32 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=googledot-cursor-theme
-pkgver=1.0.0
+pkgver=1.0.1
pkgrel=1
pkgdesc="Cursor theme inspired on Google"
arch=('any')
url="https://www.pling.com/p/1215613"
license=('GPL3')
depends=('libxcursor' 'libpng')
-makedepends=('yarn' 'npm' 'python-clickgen')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/ful1e5/Google_Cursor/archive/v$pkgver.tar.gz")
-sha256sums=('c83c3037a8e8e0b473467b3ed8db5ee0328dcaded38290d660e035cd01a0288a')
+makedepends=('python-clickgen')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ful1e5/Google_Cursor/archive/v$pkgver.tar.gz"
+ "$pkgname-bitmaps-$pkgver.zip::https://github.com/ful1e5/Google_Cursor/releases/download/v$pkgver/bitmaps.zip")
+noextract=("$pkgname-bitmaps-$pkgver.zip")
+sha256sums=('5eaaa21cb96e9c310d78dbb577e4c1109f6aa5e96c0dc054abb6c7b097a4a2cf'
+ '61c0bff15a77cacf5367c5172bfe5014af258cfa9fbfa5df5c65f8d3aea095c5')
+
+prepare() {
+ cd Google_Cursor-$pkgver
+ mkdir -p bitmaps
+ bsdtar -xf "$srcdir/$pkgname-bitmaps-$pkgver.zip" -C bitmaps
+}
build() {
- cd Google_Cursor-$pkgver
- yarn install --cache-folder $srcdir/yarn-cache
- yarn compile
+ cd Google_Cursor-$pkgver/builder
+ python build.py unix
}
package() {
cd Google_Cursor-$pkgver
install -d "$pkgdir/usr/share/icons"
cp -r themes/GoogleDot "$pkgdir/usr/share/icons"
- chmod -R 755 "$pkgdir/usr/share/icons/GoogleDot"
}